New additional USB installation

A few days ago, I acquired a Tanix Tx92. It was such a wonderful experience installing CoreElec on a 4G usb that I decided to install upgrade a new larger 64G usb drive so that I can try retroplayer. Unfortunately I kept having this “Error in mount_storage: mount_common: could not mount LABEL=Storage” message. My previous 4G usb drive still works fine.

Can someone help me? Please.

How did you upgrade? What did you copy and from where. Was anything installed on the internal flash on the box previously or was everything on 4 gb usb drive?

Have you tried to clone 1 USB drive to another? it appears that it has not been an exact copy if this is the case.

  1. The new 64GB USB stick was a newly flashed (rufus) with the same latest release CoreELEC 9 as the previous (still working) 4 GB USB stick.

  2. I used gxm_q200_3g dtb as recommended.

  3. I flashed the test Sx05RE-Amlogic.arm-2.3-Generic.img on a new 16 GB USB stick. It can’t boot with the same message “Error in mount_storage: mount_common: could not mount LABEL=Storage”.

  4. The only plugin I installed in the working 4 GB USB stick were youtube music and its dependencies. Everything was on the working 4 GB USB stick, nothing was installed on the internal box.

  5. The internal Tanix Tx92 S912 box was earlier flashed with custom recovery TWRP and still on original ROM. I restored its original boot record. It is still working fine.

  6. I am a complete noob but I tried LiveCDs cloning and partition copying with Clonezilla and GParted (GUIs not commandlines) with no vail.

Thank you for such swift responses.

It appears that you have two partitions somewhere named storage from the error Mount common. So, coreelec is confused which one to choose. Try renaming the storage partition on your usb to something else, say, storageback, and see what happens.

This is not an official CoreELEC build, these forums are for official builds, I suggest you post in the Sx05RE thread.