New Beelink GT KING PRO CoreELEC 9.2.0 SAFE MODE


We just received a new Beelink GT King Pro, with SD Card containing CoreELEC 9.2.0, but it always boots into Safe mode.
We tried solutions which have worked for others: renaming profiles.xml, renaming .kodi folder & searched for 0b sized files under userdata&temp folders, but there were none of those.

Our full log is located

Maybe somebody can have a look at it.

Thanks in advance

Have you tried the latest nightly to install on it?


Not yet.

Maybe there is a link for update guide? Or should I burn a clean install 9.2.0 with latest nightly?

I have tried to boot from a USB instead of SD which was included in the box, with CoreELEC 9.2.1, but it was looping even without entering the safe mode.

Thank You.

Update did not help, same problem.

What do you mean safe mode? CoreELEC was rebranded, and the default theme color is now the maroon red, it doesn’t mean you’re in safe mode.

@TheCoolest - when CoreElec starts it shows a window with SAFE MODE written all over it.

Updating 9.2.0 did not help, however clean install of version 9.2.0 did the job. Version 9.2.1 does not work either, it just loops forever in the booting stage.

@Pelican - thanks for the tips.

Make sure that you’re using the correct DTB, you probably have a rev A SoC, which needs the revA dtb.