NEW Repo for Remote files (Thanks to Betatester)

You said you can’t get the factory code right, so you haven’t created the conf yet.

I’m confused

Was still busy. Have now passed the factory code. Just took an x96 example remote.conf.
Values are hexadecimal instead of decimal.

Tried it and most buttons are working:(x88 king)

remote.conf (2.1 KB)

This one should work.

x88 king

Uploaded to repo

Goodmorning everyone.
I’m happy with how Coreelec works on my system (Bqeel Android 9.0 TV Box Y8 MAX 4G RAM 64G ROM)
You would make me happy if someone explained to me the simplified procedure cu how to operate the remote control that I only need to start the box.
I tried but I’m a noob
I add a big thank you for the work you do

You might get more help if you posted in the remote thread.

I’m afraid unless someone has already created a remote control, you will have to create one yourself.

There are two types of remote, conf & meson.

In the remote repo are documents to try to help.

So post in the remote thread, & tell us at what point you are unsure of.

Thanks for the answers.
i tried using inject_bl301 but i wasn’t able to make it work, it’s too complicated for me.
I used to wake up with Yatse when I was connected with a network cable but unfortunately it doesn’t work with wifi

I have added your device and remote picture in your post. If it’s not your box and remote let me know.
I’ve moved your post and replies here.

Bqeel Y8max X3 is exactly the same as H96 max X3 , Vontar X3, HK1 X3 etc. but may have different remote controls (like the one you have or with less buttons as mine which is H96 max X3).
If you scroll up you wil find all of them.Choose the one which is like yours.
Also injecting BL301 is very easy and after that everything functions perfectly (ON,OFF etc)

Sorry if I’m OT asking here, I’m new. Which version of CoreELEC do you use with Y8Max? I have the same device. Did you solve with remote?

as ath156 says, your device is the same as the H96 max x3, etc (see post above)

so go to the remote repo & try the remote files from there.

I assume you need the latest version of CE, look in the downloads page.


remote.conf (2.1 KB)
remote.conf for T95Z PLUS and probably KM8P(s912 both and same remote). Somehow the umc zpro (s905x) also works with this file.

Uploaded to the repo

another remote.conf, this time from ‘smart tv box’. That’s the name on the box. It’s a dual core 1/1.2ghz old box.remote.conf (2.1 KB)

Picture of remote would be usefull

1 Like

it’s the remote you see last topic above. It has like all of the buttons and even more. Changed it just now, cause still didn’t completely work.

Betatester is working on a new remote repo. when it is up, there will be a way to submit remote files including a picture & how to name it.

  1. First research if the Remote Control Unit (RCU) is already listed in the repository
  2. Include the full name of the RCU (ex: L8star G30)
    if the RCU came with a TV Box, the name of the TV Box (ex: Xiaomi Mi Box S) has to be included
    strong text
  3. Include a picture of the RCU
    if the RCU came with a TV Box or USB dongle, they have to be included in the picture
  4. The minimum picture size is 500x500 pixels with the unit and its peripherals clearly visible
  5. The files have to be archived in zip format

this is a brief preview

The new repo is here Repository for Amlogic & Meson IR Remote Controllers

Please follow the protocol to upload new remote files.

1 Like

sorry, but can’t you make something more with the remote itself. So like a picture of the remote and a download link to it if you press the picture? Then you can just search more easy for your remote, since a remote can be compatible with more boxes. You could just as well name the remote file zip and the jpg the same and throw them all into one big folder.

*after some research, might be not a good idea. Although some remotes might look the same, internal they aren’t. Maybe the remote must look exactly the same, so all the same buttons at the same place. Some remotes have some buttons right at another place but further look the same. Then it’s still a total different remote, so the remote.conf won’t work. Can’t you make the folders remotebased or add a remotebased folderstructure? So, like the folder has a jpg on it you can click on to open the folder. Inside that folder all the remotes that lookalike.
Then there’s something else, it seems some buttons of a remote won’t be scanned by the box coreelec. So i guess that’s a bug that needs to be fixed in a later version. @anon88919003