Newbie: SMB shares on Windows not accessible (Error)

Hi,
I’m coming from Android, installed CoreElec, everything seemed fine until I tried to connect to my shared drives I was previously accessing in Android.

I’m using a Venz V10 (Android) box. I have an external USB drive with all my films that is connected to my Win 10 1607 LTSB computer. Both are connected to the router via ethernet. This setup worked ok with Kodi/Android but no longer :unamused:

When trying to add shares in Kodi, I can get as far WORKGROUP and then see my PC, Laptop, etc…but none are accessible: When I click on one to add it as a share, I get an ‘Error: Operation not permitted’ message…

I was however able connect another share - a Popcorn-like device - via NFS & Samba that was connected directly to the router, so the problem does seem to come from the Windows side of things.

I enabled all versions of Samba, same problem. I tried typing in the address manually when using ‘Add network location’ button as suggested elsewhere on this forum…same problem
Any ideas? :smirk:

Thx in advance!

It’s not working.

Use the option add network share and add server name/IP and name of the shared folder.
I am not sure if a username and pass is required. I added in Windows the user media and pass media and it’s working fine.

Check your Windows Samba folder sharing settings. Windows 10 samba sharing works (you may need to point to a valid local PC user: <PC_NAME>\<LOCAL_USER>).

In Samba folder sharing on the router you may need to enable ‘Simpler share naming (without the disk name)’ if this option is possible.

Sharing of NFS folders on the router requires partitions formatted in ext3 or ext4.

In short, everything works in CoreELEC, you just need to check your settings.

Use NFS instead Samba.
Im using along time haneWIN NFS Server for Windows.
Works great!

As I said in my OP (last paragraph), I did that too.

As I said in OP, iNFS AND Samba works but only for a share that’s directly attached to the router.
So when I choose an NFS share, it only shows the share attached directly to the router, nothing on the Windows side of things.
Are you saying there’s something that needs to be done on the Windows PC to enable NFS sharing?

you may need to point to a valid local PC user: <PC_NAME>\<LOCAL_USER>

As I told Portisch as well, it’s in my OP, I did that, it didn’t work.
my path is smb://MY-PC/Movies

In Samba folder sharing on the router

Is that really what you meant to say…router, not PC? I’m not aware of a share folder setting on routers? If PC you meant, then you’ll see by the address I showed above that it doesn’t show the disk name so I guess that’s what you were saying?

Since with NFS I can’t even see the shares that are on my Win10 PC, I’m not even too concerned about that as it seems for now to be a bigger obstacle than SMB!

As I told, use:

Path smb://MY-PC/Movies
User MY-PC\<local_pc_user>
Password <pc_user_password>

this works for me

And be sure if in windows the user have access rights to the shared folder.
I just added Everyone to the folder with read/write access.

Doesn’t work for me, same error.
Thanks anyway for trying :smirk:

Yes, I had done the same as well and added Guest as well for good measure. Still doesn’t work.
Damn, don’t what more to do!? :unamused:

did you try \\<your_tv_box_IP>\

tv box IP?
I’m talking about a USB hard drive connected to a Windows PC that has my films and that I’m trying to have populate my shares in a CoreElec box. (All explained in my first post)
I think you misread.

Could the firewall on your PC being blocking access?

Now I see… This is not CoreELEC related.
SMB sharing In Windows 10 has always been a pain in the ass for me.
What I learned so far:

  1. With SMB3, browsing SMB shares in network discovery is not possible.
  2. You cannot share a folder as public (without account&password)

Nope, didn’t work either. Disabled the firewall for both private and public networks…same.

Ok but…what’s the solution then? Where do you keep your Kodi shares?

on an external harddisk connected to the TV box

I guess that’s the way to go then.
I recently bought a Synology NAS but haven’t yet explored it’s functionality nor connected it to the CoreElec box. I’ll try that next and see how that goes…

Try to enable smb1 in windows
In CE i configured the SMB share in:
sources.xml

PC smb://192.168.x.x/share true

and passwords.xml

smb://192.168.x.x/share/
smb://:@192.168.x.x/share

User/Password created in windows