Nexbox A95X (1gb) power-on from IR remote?


First, I thank you for developing CoreELEC. I have a spare Nexbox A95X (S905H, 1GB) collecting dust but now with CoreELEC it is once again found its place in my living room.

I managed to install CoreELEC to it via SD card. Even though the box says “A95X” in the front, at the back of the box there is a sticker indicting that the processor is S905 and has 1GB ram. I used “gxbb_p200_1G_100M_RealtekWiFi” as the device tree and it worked properly. All 4 cores of the CPU were identified, with working USB, ethernet, and WIFI. I was happy.

The IR-remote that came with it did NOT work out of box I also followed this guide (How to configure IR remote control) to customize a configuration file. Everything was working, including power-down using the button. However, I cannot “power-up” (or is it “wake-up”?) the tv box using the IR-remote, instead, I have un-plug and plug-in the power core (there is no physical power on/off button).

My questions are:

  • using Meson-ir, does “KEY_POWER” (which I assigned the red on/off button to) actually a) turns off the machine completely, or b) put the machine into stand-by/sleep mode,
  • using Meson-ir, how can I use the IR-remote to “power on/off” the machine?
  • I found this thread (NEW Repo for Remote files (Thanks to Betatester)) which contains remote configuration files for various amlogic box/remote. However, these .conf files has very different structures than the guide for Meson-ir. Granted I only spent an hours or so (at work, without access to the tv-box for tryout), will these remote configuration file allow me to turn on/ff the machine?
  • or should I follow this guide (how-to-configure-ir-wakeup-code/5282), or is that guide specific to Odroid N2?

thanks in advance,

This model had the same issue with LE.
Someone made a fix for the 2gb/16gb back then to fix uboot for power on.
Not sure about the 1gb/8gb .

Thanks for the prompt reply. I am content to leave it on 24/7 for now. when I have more time I’ll search the forum in LE to find the fix you are talking about,


It’s not worth it, messing with uboot will only lead to a potential brick.

These devices only use <5w of power and your looking at a cost of €6-7 a year if you leave it on 24/7 for the whole year.

Don’t waste your time because that costs more than what you would save. :slight_smile:

1 Like

Some time ago I successfully tested these boards with gxb_p201_v1 uboot from CE-git repository. PCB was blue, SKhynix RAM H5TQ4G63CFR-RDC (CL13) and the simple eMMC memory. However, if you are using Android 6 you will most likely not be able to boot to Android since this uboot is from Nougat branch

Understood, I don’t plan to spend time playing with uboot.

Coincidentally I have MCE remote that also worked (out of box). I find the MCE IR remote much more responsive then the standard IR remote with Meson-ir.

Problem with any IR remote is of course the line of sight. I have several PS3 BD remotes (bluetooth) that I used with a Intel NUC/Libreelec. I haven’t had time to test it with CoreElec. Is PS3 BD remote supported by CE?

Just to answer my own question: The Sony PS3 BD remote (bluetooth) works without additional configuration: all has to be done is to pair the remote with the bluetooth receiver.


But you cant power on by BT, and as for leaving your unit on, HDD sleep is still random so no good if you have a hdd directly connected