Nexbox A95x , S905x, only boots to black screen from SD card, won't boot from USB

#1

Hi,

I have bought four or five A95x boxes and successfully installed libreelec or Coreelec on all of them. I think my previous boxes were all 2G/8G models.

My most recent A95x is a B7N like the others, but this one is 2G/16G model.

Anyway, for some reason I just cannot get this box to boot Coreelec (or libreelec) correctly from SD card or USB. This has been frustrating me like crazy for several days so if anybody has any suggestions i’d really really appreciate it. I’ll do my best to describe what I have tried so far:

  • various img.gz files to create bootable USB. ( i had used the very same USB drive successfully for previous libreelec installations on other boxes) All likely dtbs renamed to dtb.img. In all cases toothpick method boots to android recovery. USB simply won’t boot.

So, I went and bought an 8GB Micro SD. Tried with both Libreelec USB-SD creator and Rufus, various versions of Core / libre along with every possible dtb.
With SD card inserted in A95x box it seems to try to boot from SD card every time (weirdly, with or without toothpick). However after Nexbox splash screen I am left with a black screen only. There is no cursor / prompt however I can type on this screen via usb dongle keyboard.

Even stranger when I left LibreElec 8.2.3.1 attempting to boot overnight I woke up to find that, eventually Libreelec had booted. This must have taken well over an hour though. I plan to installtointernal but was afraid of doing so in case the ridiculously long boot time persisted after I had done so. Do you think it would be worth trying this?

Finally I made a bootable USB SSD with Rufus - this seems to behave the same as the SD card - boots every time but only to black screen ??

Any suggestions about why this could be happening? Could I have a faulty box? Got super unlucky with bad USB drives AND SD card?

Thanks so much if anybody can help me out of this super frustrating situation - pleas let me know if there is more info I can provide.

Thanks so much in advance!

P.S - I could have equally posted this on Libreelec forums but I just can’t find anywhere to register there? Did i miss something ?

#2

No idea on your problem, but re the LE forum I think registration there has been temporarily disabled due to spammers.

#3

Maybe it boots, but you just don’t see the picture… ?

#4

Thanks for the reply, but I dont think it is booting fully because I am able to type on it. (Though there is no prompt). Also when left overnight I did find libreelrc setup on the screen. So perhaps it does boot, but ridiculously slowly. In that case any idea if should expect the same loooong boot after installtointernal? Or might that work correctly?

Thanks again!

#5

I’d first find out why it boots so slowly before attempting to install to internal.

#6

Maybe your choice of SD Card / USB Sticks ???
Your hardware is listed in the download helper which saves you fiddling with device trees.
Use it and flash the image again.
If you use Etcher you can direct flash the img.gz without any unzipping.
download%20helper
Please disclose your choice of SD Card Brand and specs.

#7

Thanks guys. The SD card is a 8GB Micro SDHC, no brand listed, just says Made in Taiwan.

You think that is a likely culprit? I was suspecting the box due to the fact that I had used the very same USB drive before to install Core/libreelec on other boxes and only bought an SD card because the USB method wasn’t working. So i thought it would have been really bad luck to have two different unrelated bootable media issues. I bought the only SD card available at my local shop - is it common for cards which otherwise appear to be working fine in windows etc to cause problems like this?

Also, is it normal that the box will attempt to bbot from SD card anytime SD card is inserted , without any need for toothpick method etc?

#8

Sorry to bump - anybody have any ideas? Would love to get this A95X working like the other four I installed Libreelec / Coreelec on,but have already devoted so many hours to trying all the different variables. Would really appreciate if somebody had any similar experience re SD cards etc

Thanks so much :slight_smile: