Nightly builds (NEW)

Just to get you right: you are running CE 9.2.1 on your old 905X box and HDR to SDR works correctly for you?

Yep. I’ve compared both boxes to my PC running MPC-HC with MadVR and the old one is doing it properly, with vibrant colours and solid blacks. The new one is now doing conversion with the latest build, but colours are quite dim. It’s definitely doing conversion though, because if I disable it the the image is super washed out, but it’s still not right.

It’s not outputting AAC to PCM properly either. On the old box I get multi-channel output, but on the new one I get stereo only and it causes everything to stutter. If I set it to 2.0 channels the stuttering issue is resolved, but still no multi-channel audio. DD transcoding does work though. It also seemed to have an issue with DD+, but I think that might just have been a dodgy track as it didn’t work on the old box either and was super sped up on my PC.

Has Dolby Vision support been added or is the logo embbed in your test file?

Great news to me, have to brush off the dust of my old 905X box and see, if tonemapping works on my box as well. It doies not really work on my odroid n2, as you said: colours are dim and washed out. Thanks!

Could I ask @Compent or anyone else running TvHeadend server on their box if they’ve noticed a temporary halting of video but not audio when watching? I’m not sure if it’s just been a glitch with my set up but I’ve had a couple of times when the video has stopped for a second or two. It resumes normally with no “fast forwarding” of what’s been missed. I’ll be more vigilant now I suspect something’s going on.

On a lighter note, I have cured the unresponsive remote that only scrolled intermittently by changing the batteries! Who says that end users can’t problem solve?

P.s. I was watching BBC1 or ITV1, both in HD, when this happened.

At the moment none, I normally use a usb keyboard anyway, it’s something I’ll look into in the next few days though.
This looks to be the same remote so I’ll give it a go. NEW Repo for Remote files (Thanks to Betatester)

The remote obviously doesn’t work out the box with Coreelec but I’ve noticed it won’t turn it back on either when I shutdown from coreelec, I have to do the power, if I shut down from android the remote can turn it back on.

@mentasm S905X3 support has only been in CE for a few days now so it’s not at the same parity as S905X yet.

There is a menu option to enable HDR2SDR now as some of the devs was against having it on auto like the previous kernel.

Audio related issues will be solved when one of our devs with a L-PCM compatible receiver receives their Generic S905X3 device which is due in the next week or so.

@NathanX please read as above for HDR2SDR.

Will check that on the odroid n2 as well as on my old 905X box. May take some days due to time of the year, but will definitely report on that!

Thanks for the update. I have already tried the various HDR2SDR options on the last two nightly builds and both auto and on give the same results (i.e. it’s performing tone mapping, but colours are very muted), so it’s definitely not acting the same as the stable build on the S905X where colours look vibrant as they should. Great news about the audio! I realise this is a WiP and I’m very thankful for all of the work you’re doing. I’m sure any wrinkles will be ironed out :smiley:

Edit I will try and find a spare SD card and make another nightly build for the S905X to see if the tone mapping operates the same as it does when using the stable build.

I’ve not noticed anything but haven’t watched BBC or ITV yet but later I will try and report back.

X96 Air P2 lan 1Gbps

wifi work

lan 1gbps don’t work

help me thx you

Try the following DTB

Test this dtb last build no work wifi. X96 905x3 2gb 16.thank

V8 pro 905x3- 4g - ethernet 100. Now everything is working but 5g wifi network and standard too slow only 20 megabytes

X96 Air P2 lan 1Gbps
This DTB works for me.

@DroiDMester if you have made changes to the device tree then let us know what they are so we can incorporate the changes into our builds.

Made changes by TheCoolest here how to configure VFD

But this change also improved the Gigabit LAN port, which hasn’t worked so far
And WIFI worked, but only on the very first start

Thank you. X96_Air_P2 Gigabit LAN work for me.

Updated to 20191220 (from 20191219) on S905X2 (A95XMax) and initially the GUI was not being loaded again and I had to switch off and on again to get a full boot.

I have also noticed that now whenever I select reboot (whether from Estuary or Confluence skins) or run reboot after SSH in to the box, the box powers off rather than reboots.

Another oddity that I have found is that although the on screen slider controls for adjusting brightness and contrast move back and forth, no change is made to the video display and this is with all video (stream, local, live TV). I don’t know if this is related to this build as I’ve not used the controls for a while. I’ve tried Estuary and Confluence skins to eliminate issues with a custom skin.