Nightly builds (NEW)

Try the following DTB

Test this dtb last build no work wifi. X96 905x3 2gb 16.thank

V8 pro 905x3- 4g - ethernet 100. Now everything is working but 5g wifi network and standard too slow only 20 megabytes

X96 Air P2 lan 1Gbps
This DTB works for me.

@DroiDMester if you have made changes to the device tree then let us know what they are so we can incorporate the changes into our builds.

Made changes by TheCoolest here how to configure VFD

But this change also improved the Gigabit LAN port, which hasn’t worked so far
And WIFI worked, but only on the very first start

Thank you. X96_Air_P2 Gigabit LAN work for me.

Updated to 20191220 (from 20191219) on S905X2 (A95XMax) and initially the GUI was not being loaded again and I had to switch off and on again to get a full boot.

I have also noticed that now whenever I select reboot (whether from Estuary or Confluence skins) or run reboot after SSH in to the box, the box powers off rather than reboots.

Another oddity that I have found is that although the on screen slider controls for adjusting brightness and contrast move back and forth, no change is made to the video display and this is with all video (stream, local, live TV). I don’t know if this is related to this build as I’ve not used the controls for a while. I’ve tried Estuary and Confluence skins to eliminate issues with a custom skin.

Just done today’s update on my N2 running from SD card and I’ve confirmed something I noticed the other day. When rebooting to apply the update, there’s no video output until the Kodi home screen reappears and the update has been applied. So all the messages about unpacking and updating the kernel and rebooting are unseen as is the CooreELEC logo on rebooting. I could only tell that something was happening by watching the red and blue lights while this was going on.

Subsequent reboots do not show the Coreelec logo too.

Let me know if there’s anything I can do to help you identify the reason.

1 Like

@sonofdibnah we are aware of this and looking into it.

updating to nightly today … the x96max vdf (s905x3) no longer works.
I had to put the corrected dtb manually.

please update the dtb in the next revision.

correct dtb link How to configure VFD

Hi x96 905x3 2gb build day 19 @thecoolest test usb ethernet gigsbite but no work in Port USB 3.0… Need help. Use same yiu

Hello, I’m new to the forum, but I’ve been using CE (and LE before) for some years, from the times of S805. The latest months I’ve been using an Odroid N2, but I have still running some old Chinese boxes (S905X and S912).
Now I’ve got a new box to test this new builds. It’s another Chinese box, X96 Air, S905X3 2GB. It’s very cheap (22 €), so I don’t hope it’ll be perfect. Yesterday I installed CE on the box with a new uSD card and restored a backup from another box. No problem at all: boot ok, colors ok, wired network ok, remote database library ok, even TVH client works (server on another box). I don’t use wifi, bluetooth…
By now, the only problem I found is playing 4K files. The box is connected via an AVR (box --> AVR Denon --> Panasonic OLED TV). Playing HD files was ok, but when playing 4K files the image was black (the sound was ok). Also the TV didn’t show the video mode change.
I tried with whitelisting. When whitelisting only all 1080p modes, 4K file was playing ok, but in 1080p.
I tried disabling CEC (I don’t use it), but no success.
My last try was connecting the box directly to the TV and… it works, it plays 4K files with video ok.
So I think is an issue between the box and the AVR (it’s a Denon AVR2400). I’ve tested the same configuration with other boxes (N2, S905X and S912 boxes) with stable CE builds and never had such problem.
If needed, I could try installing the new build on the N2 to see if it works. Also could provide logs, of course.
You make a fantastic work. Big thanks.

Hi I have X96Max+ (4g,64g) I am running the “nightly_20191219” have changed the dtb to the one listed above (modified by “The Coolest” ) and can confirm that the display works perfect and that the gigabit lan is working, tested with “ethtool eth0” via SSH access. for anybody that needs wifi access I have tested with plug in usb wifi dapter and all works fine. Massive thanks to all the Coreelec team for their continued great work.

I hope that support for s912 will be implemented in this new build

In Kodi Settings, under CoreELEC tab, enable the 4:2:2 chroma option and reboot. Then try again.

I tried and it works. Thanks. But then I had some other doubts.
Regarding the N2 configuration, I see it’s also configured as 4:2:2. I remember changing that config to test, but I think I played 4K from the first day with the default config. So I tried changing to 4:4:4 and it doesn’t work.
Regarding the AVR documentation, it’s clearly written that it’s capable of handling 4:4:4 signals. In fact, it has 2 modes for 4K format: standard and enhanced (this is for 4:4:4). And it’s in enhanced mode. Changing from enhanced to standard, and then again to enhanced, it gives me a message like “your TV it’s not capable of handling enhanced signals”.
So I go to the TV menu and search for ‘something’. Find an option called “HDMI Auto Setting”. It has 2 options, Mode1 and Mode2. The on-screen help says “if Mode1 doesn’t work change to Mode2”, and I do it. And now my N2 and my new box can play 4K files in 4:4:4 (both tested).
Thanks again.

lrwxrwxrwx 1 root root 0 2019-12-22 09:12 /sys/bus/sdio/devices/sdio:0001:1 -> …/…/…/devices/platform/ffe03000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1

I need udevadm output and not a directory listing, use the correct command I posted.

It looks like I have the same device as filkint.
Here is the output of the requested command: