Nightly builds (NEW)

Hello, I upload success the kodi crash log this time is blow:
thank you for your patient.

@Speederer thanks for providing this.

You have the RTL8822CS which we don’t have a driver for in our builds and this is why WiFi is not working.

I have compiled this and you can test it by SSH’ing to your device and executing the following commands.

insmod ./8822cs.ko

if it doesn’t work after entering these commands then please execute

dmesg | paste

and paste the resulting link.

insmod: ERROR: could not insert module ./8822cs.ko: Invalid module format

Please read the entire post.

dmesg | paste

10 posts were merged into an existing topic: Unsupported dtb

Please try the commands again but remove the first file you downloaded first

rm 8822cs.ko
insmod ./8822cs.ko

no error message, apparently installed, but there is no wireless network setting up the networks

You must have a different wifi adapter in your device, please provide the output of

udevadm info /sys/bus/sdio/devices/sdio* | paste

Atmos/TrueHD sound don’t work latest nightly (20191222). Ugoos AM6.

Unknown device “/sys/bus/sdio/devices/sdio*”: No such device

Fn-link 6222B-SRB (main chip RTL8822BS) specification => Fn-link 6222B-SRB

We already have the driver for this in our builds, if your system can’t see the module then it is likely you need a custom dtb for your board, maybe @boot2k3 can help you as he has experience with this.

@boot2k3 are you able to confirm Atmos/TrueHD as you have the Ugoos AM6?

I will check this 4 hours later.
I don’t think it could be only one box related…

I asked user to check AM6 on latest nightly, true hd is working…
Check that you select HDMI multi ch and HDMI all passthrough settings

Will do that, thanks a lot for your help!

To X96air users:

Can you turn on box by remote?
Mine only turn on if i change source on tv.

ok strange, no settings changed from previous nightly and settings are correct.

Try to start the same file twice. It possible after some specific sequence you hear silent…
Or try to change output to something different and return it back to hdmi… just as assumption, don’t know what is wrong

I checked it too this morning on AM6, TrueHD works.
I don’t have Atmos receiver to check, but it should also work.