Nightly builds (NEW)

Best would to to cut the file after a few megabytes.
In linux I would use dd.

This is excellent, free and quick.

dd if=Hell.or.High.Water.2016.German.EAC3D.DL.2160p.UHD.BluRay.HDR.Dolby.Vision.HEVC.Remux-NI
MA4K.mp4 of=Hell.or.High.Water.2016.German.EAC3D.DL.2160p.UHD.BluRay.HDR.Dolby.Vision.HEVC.Remux-NIMA4K.sample.mp4 bs=5M count=1

nightly_20200702 on an Odroid N2 has a problem with resolution.ini

If I change Kodi’s GUI to 2160p when I next reboot the box it hangs at the CoreELEC logo.

If I then SSH into the box and quickly delete resolution.ini and reboot before it gets rewritten then the box boots fine in 1080p mode.

However if I then change Kodi’s GUI to 2160p, next reboot the box hangs again and I have to go through the whole process of deleting resolution.ini again to get it to reboot.

journalctl -l --no-pager
http://ix.io/2qPL

Looks like a error in resolution.ini.
Until it’s solved you can override automatic display detection by enable this in config.ini:

Then it should work as before.

Thanks, that worked perfectly.

About hdmi mode setting in config.ini:
I run 9.2.3 on a N2.
Initial install was 9.2.2, then some nightlies, then 9.2.3 stable.
From my /flash/config.ini the “hdmi mode” section is missing.
I did check the 9.2.3 image, and the newer config.ini indeed has that section.
Maybe the file was not updated on latest update?
Is it a known issue?
I suppose it is safe to just replace the file with the newer one, or manually edit/add the missing sections?
Or should I re-update or re-install?
Thanks.

The config.ini doesn’t get updated after install, it also doesn’t do anything until edited by the user so it’s default contents are more documentation of what you could add to the file, then specific sections.

If you just add the following to the end of the file it will have the same effect as if you uncommented the the line pointed to above.

hdmimode='1080p60hz'

Great, thanks.

Can you please enable kodi debug then remove your config.ini changes. Then set GUI to 4K and reboot. ssh to your box and pastebin kodi.log. Thank you.
I have a N2 and OLED 4K TV and I can’t reproduce this.

Something went wrong with your sample. There is only black screen no matter which player I use.

Please make a better sample. Probably you need a bigger one. And please test it yourself if it shows your stutters. Also don’t embed it here but send a download link.

Thank you

@Ray Here you go
http://ix.io/2qQb

And this is the screen after boot, Kodi seems to be running in the background

Check your Gui settings. You probably have the “resolutions” tags inside. I had them too again inside lately for a reason I can’t explain.

Also can you post your resolution.ini?
Also do you use native 4K GUI or the scaled default one?

GUI 4K native.

resolution.ini

hdmimode=2160p60hz
frac_rate_policy=0

Yes, I have the resolutions section in guisetting.xml but removing them makes no difference.

Please try to disable native setting just for testing.
EDIT I could reproduce the issue with GUI scaling disabled.

Yep, setting Disable GUI scaling to off allows Kodi to run fine, albeit without a native 4K GUI

At least we narrowed it down. I will look why this is happening.

1 Like

Thank you :+1:

Can that one be used to force 4K output? I’ve sometimes noticed that the box switches to 1080p, probably because the TV didn’t manage to tell its capabilities on time. It’s irritating having to check and possibly change the settings every now and then, especially with nightlies which require rebooting more often.

I’m also having issues sometimes resuming playback of MPEG2 encoded videos, being inside mkv or an ISO. With ISOs, I always try to playback from the start because jumping directly to the point where I was just won’t work but you need to open the main menu. With mkvs, I select to resume but nothing happens. No ‘buffering’ message whatsoever. Then after waiting for some time, retrying and this time choosing to resume from the beginning makes it work.

I think this started happening some time after v9.2.2 but I’m not exactly sure. Which debug log options should I choose to make sure I catch this one in the log?