Nightly builds


#21

By the way:
On the right side of each listed file there is an “i” symbol.
If you click on it, the MD5 and SHA1 hash is being calculated and displayed.
This should also be enough to check whether the downloaded file is valid or broken.


#22

Perfect!
Thank you. :wink:


#23

hi, do I must deactivate auto updates on coreelec? because I habe the latest nightly on m s905 installed and coreelec make an auto update to the last official version (8.95.0)


#24

Yes, you should disable auto update for now.
As soon as I had the time to implement Raybuntu’s script, you can re-activate it (after adding my server as a custom update channel).


#25

Presently, stable builds will always over-rule (unstable) nightly builds and present as an update.


#26

Tried two downloads dated 25th & 26th for 905 device … img.gz.

CoreELEC-S905.arm-9.0-nightly-20180825-relkai.img.gz
CoreELEC-S905.arm-9.0-nightly-20180826-relkai.img.gz

Neither MD5sums available matched what my PC gave me. :frowning:

I did not yet have the opportunity to install either, but I expect they will work ok, as my download was not interrupted in either case.


#27

I just tried it with the file “CoreELEC-S905.arm-9.0-nightly_20180826_relkai.img.gz”.
Directly on the web server:

md5sum CoreELEC-S905.arm-9.0-nightly_20180826_relkai.img.gz
dde98015ce45a5cbcf129ca324872cbf CoreELEC-S905.arm-9.0-nightly_20180826_relkai.img.gz

This matches exactly the md5 hash shown on the website.


#28

I guess I must have got a bad download so

$ md5sum './CoreELEC-S905.arm-9.0-nightly-20180826-relkai.img.gz' 
110eda7819a39ee4b3fd0e9777d6c2a7  ./CoreELEC-S905.arm-9.0-nightly-20180826-relkai.img.gz

I will download again. Thanks.

Scrap that!

I have just noticed that the .gz image had somehow been extracted but the name not changed.
So the md5sum I got was that of the .img file and not of the .img.gz file.

My apologies for my error.

Thanks.


#29

No problem. Glad, you solved it.


#30

Direct update within CoreELEC now possible.
I’ve added the instructions to the first post.


#31

Just a heads-up. In your instructions for setting up a custom update channel the path

/storage/.upload

should be

/storage/.update


#32

Thank you, Nanouk. It’s fixed in the instructions, now.


#33

NP. You beat me to it :grinning:


#34

I did everything as the steps in the first post but when i hit update channel select CoreELEC-9.0 it’s blank.

I want to add this on my odroid C2 but unfortunately it doesn’t work

EDIT: it works now probably you have to wait some time to appear the update channel.

Thanks a lot!


#35

Yes, I also had to leave the settings once until the version showed up.


#36

Just wanted to say many, many thanks for these builds. Sometimes it’s agony waiting on the team to pinch it off when I see a commit that applies to my boxes.


#37

You are welcome, @Jaaxx.
The main work is done by the devs, of course. They are really doing a great job.


#38

Thanks for the builds. As far as I understand, only the patches to CE are applied but not the patches to core KODI. That’s a shame because it would solve the problem of different database versions used until the CE stable build catches up. Any chance of adding KODI patches as well?


#39

Kodi patches are being merged regularly.
If you take a look at the system information, it should already show “Kodi 18.0-Beta1” along with the Git commit tag being used.
As far as I know, the database version of Kodi doesn’t increase anymore after the first beta, because no new features are going to be implemented, but bug fixes only.


#40

Hi @relkai
When the Dolby sound is set, the sound is stutter.