No Audio from Radio Add-on

Hi all,

N2, CoreELEC 9.2.5

I have installed the audio.radio_de v3.0.3 add-on and while I have audio on many stations, many do not. The non audio stations seem to be connecting as the current song title is at the top of the screen, but no audio.

I enabled debug and found no errors at all, so that was not much help. Any ideas greatly appreciated.

TIA

Have just found the cause but do not understand why enabling Stereo Upmix is necessary.

Any explanation as to why I must enable this option would be appreciated? Is there any downside of enabling this?

I’m sorry @Betatester but I don’t understand what you are trying to tell me.

BTW - I’ve just discovered another Radio Add-on that gives audio to the same stations that audio.radio_de v3.0.3 does not, without turning on Stereo Upmix. So now I’m even more confused.

The solutions are almost always simple, you just have to analyze the problem with your eyes open. Kodi can use audio passthrough, something that I always have disabled, and it has many audio decoders (2SF, ASAP, DUMB, FluidSynth, GME, GSF, Modplug, NCSF, Nosefart, OpenMPT, Org, PSF, QSF, Sidplay, SPC, SSF / DSF, Timidity, USF, VGM, WSR, YM, …). Investigate what your problem is and you will find the solution. Perhaps it is something as simple as the radio stations being turned off.

I don’t think so. Same radio station works with another add-on with Stereo Upmix OFF, plus audio works if I enable Stereo Upmix in audio.radio_de v3.0.3.

Is it possible that the particular radio stations are using a codec such as AAC? As you are using passthrough the AAC would be sent to your AV receiver. Most receivers can’t decode AAC, so you need to decode in Kodi and output as PCM or similar. It’s possible the other add-on is doing the decoding by default.

Possible, but I would have thought I would have had the same issue with AAC movies. Is there a way to find out what the codec is or what audio the add-on is outputting?

You shouldn’t really be seeing AAC in movies (unless pirated). They are usually AC3. UK terrestrial TV uses AAC on HD channels, though. If you can set Kodi to transcode AAC to AC3 and check those radio channels you might confirm that they are using AAC. It’s not something I have encountered, but I mostly use Kodi for my own audio and video rips plus occasionally using it for satellite TV.

1 Like

If I disable Stereo Upmix and Passthrough I still get no audio from many stations. I also have some AAC Audio Test Files, 2 & Multi Channel, and they all play just fine with Passthrough enabled and Stereo Upmix also disabled.

Are you using this addon?

Yes I am using that add-on. It’s the add-on that has no audio for some stations.

I use the same addon, can you let me know what stations do not play for you? Please limit to 10 stations.

I used this same addon for about 4 months last summer without any problems. Had no sound problems on any stations that I listened to; not many though, just about 10-11…

These are all stations in Sydney Australia.
Sydney’s 2CH
2GB - 873AM
2UE - 954AM

Sydney’s 2CH
2GB - 873AM
2UE - 954AM

They play for me.

Maybe try this: make a full system backup, then reset CE to defaults, install the Radio addon from the Kodi repository and see if it works.

Once you tested that, you can restore your settings et all from the backup.

That’s very odd. They also play for me, but only when using a different radio add-on.

I don’t get that, only the song details at the top of the screen.

Made a fresh install of 9.2.5 on SD Card, installed one the Radio Add-on and still no audio for the same stations. In the audio settings the only change from the default was to set the output to SPDIF.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice