No Audio from Radio Add-on

Are you using this addon?

Yes I am using that add-on. It’s the add-on that has no audio for some stations.

I use the same addon, can you let me know what stations do not play for you? Please limit to 10 stations.

I used this same addon for about 4 months last summer without any problems. Had no sound problems on any stations that I listened to; not many though, just about 10-11…

These are all stations in Sydney Australia.
Sydney’s 2CH
2GB - 873AM
2UE - 954AM

Sydney’s 2CH
2GB - 873AM
2UE - 954AM

They play for me.

Maybe try this: make a full system backup, then reset CE to defaults, install the Radio addon from the Kodi repository and see if it works.

Once you tested that, you can restore your settings et all from the backup.

That’s very odd. They also play for me, but only when using a different radio add-on.

I don’t get that, only the song details at the top of the screen.

Made a fresh install of 9.2.5 on SD Card, installed one the Radio Add-on and still no audio for the same stations. In the audio settings the only change from the default was to set the output to SPDIF.

If other stations play, then maybe you are geoblocked for those stations? Have you tried a VPN?

Plays fine with another radio add-on.

Then I am at a loss. The stations you listed play perfectly fine on all 5 of my test boxes with Tristan Fishers Radio addon under CoreELEC 9.2.5-ng. Therefore, I am unable to replicate your problem.

Maybe try CE from SD and see if it does the same?

Was doing the same with before upgrading to 9.2.5.

Could it somehow be related to me using SPDIF as the audio output?

Not that I can think off. I tried via:

  • PCM
  • Multi Channel PCM
  • S/PDIF
  • HDMI
  • PULSEAUDIO (Bluetooth)

I have sound everywhere.

Maybe it’s a hardware issue? Cable damaged? Port damaged?

Maybe try via HDMI passthrough and see if you have sound on your TV speakers?

Now that is very weird. I also play lot’s of different types of audio formats on all the videos I play and never an issue. Just this add-on.

I do have a 1 to 2 output SPDIF Adapter hanging on the SPDIF N2 output. Let me try HDMI for the audio to rule that out.

Either that or connect S/PDIF directly (bypass the adapter)

I don’t use splitters, they tend to cause feedback.

Used HDMI for the audio and the same thing, no audio. Used a VPN too and that did not help.

What is interesting is when a station is playing and you have no audio, if you move around the GUI you don’t get the GUI clicks, so there must be some sort of audio stream.

This is getting stranger by the minute.

Sorry bud. I am out of ideas. All I can tell you is that I am unable to replicate the issue you are describing on 5 different media boxes. The only other thing that comes to mind is that the audio decoder might not support certain streams, or that some RTMP streams are encoded in a way that is incompatible with the audio decoder. Or it might be a firewall issue (certain ports blocked?) But that’s a long shot. I guess it will be process of elimination now.

Thanks @Betatester for all your efforts, it’s much appreciated.

I did take a look at the kodi logs in both debug and non debug and there are no errors. Here’s the add-on connecting to 2CH:

2020-11-06 12:03:44.362 T:3911058304 NOTICE: [] get_station_by_station_id started with station_id=110498
2020-11-06 12:03:44.362 T:3911058304 NOTICE: [] __api_call started with path=v2/search/station, param={‘station’: ‘110498’}
2020-11-06 12:03:44.362 T:3911058304 NOTICE: [] __urlopen opening url=
2020-11-06 12:03:46.516 T:3911058304 NOTICE: [] get_stream_url result:
2020-11-06 12:03:47.594 T:3911058304 NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder mp3float

If I put the http stream url into my browser it plays just fine, so the connection to the source is OK.

Like you I’m out of ideas, and once again thanks.