No HDMI signal after CoreELEC splash screen

@cdu13a I still have the same result with plugging my u9 straight into the telly. No signal. The tv doesnt even recognise a signal coming through.

I had a u1 before and was running kszaq’s LE build for the s905. It worked flawlessly. The only thing I did not have was HDR which is why I sold my u1 to a friend and bought the u9.

I borrowed my recently sold U1 back from my friend and did a fresh install CoreElec 9.0.2 on a different SD card.

I had display, it was working and right through to the point I had setup how I wanted it, I tried to play something and I just had sound but no video. I thought oh great, damn I wonder what the hell is going on? I wiped the card and reinstalled the L.E custom build I was using before and of course it works flawlessly.

Im now wishing I just kept my U1 :frowning:

I’m going to catch up on my anime for the week and then play around with the u9 again and see if I can get that going.

In regards to SSH

How can i dump that info to you? How do I connect via SSH?

Thank you for your time guys.

I just got the exact issue a few minutes ago on my Tanix TX5 Pro.

Was happily using CoreElec 9.01 for a while, it updated to 9.02. I tried to reboot from within Kodi and it rebooted saying “Invalid Format” with some sort of animated logo on the screen. I powered off and on and now I get no HDMI signal after the CoreElec logo :frowning:

I had the Tanix going through my Denon AVR, I just connected the HDMI cable directly to my LG C8 and it is working.

Some weird EDID issue between CoreElec 9.02 and my Denon? I hope to resolve this as I don’t have any spare HDMIs on my TV and I also want to get proper 7.1 sound through the AVR

dispinfo output:
http://ix.io/1L3r when connected to Denon AVR
http://ix.io/1L3t when connected to LG C8 TV

Kind of regret rebooting the box now :frowning:

I tried the latest nightly and still no dice.

I downgraded to 9.01 and it still didn’t help :frowning:

Do not use the 4096x2160p resolution, some devices doesn’t support it. 3840x2160p is for UHD video playback. Is selected in the Whitelist? Disable it.

Can you please post also a dmesg | paste link?
And please use for the log the latest nightly.

I did a clean install on 9.01 and it still didn’t work. Very strange. I have been using 9.01 fine for a while. It had auto updated from whatever I clean install I did, I think it was 8.95.2. I was on 9.01, I rebooted, it updated to 9.02 and I’ve not been able to get signal through my Denon ever since.

Will do, cheers

Aw man, I think it’s something to do with this after all.

I connected directly to my TV and the UI was at 4096x2160p. I changed it to 3840x2160p and the TV lost signal! Then I changed it to 1080p and it worked through both the TV and the Denon!!

Did the default UI res get set to 4096x2160 somewhere between 8.95.2 and 9.01?

Pretty weird, like I said, all I did was rebooted having been using this without issue for months!

UHD TV’s works well with 3840x2160p but some devices support higher resolution and some devices doesn’t. I don’t see any advantage to use 4096x2160p, unnecessary resolution for “us”.

4096x2160p should always be avoided. UHD TVs have a native resolution of 3840x2160.
4096x2160 has a different aspect ration, and it also doesn’t fit into the physical pixels available on the TV, so the image will be scaled, and image quality will be lost. The image will also be either deformed or not use up the whole screen, or the edges will be cut off.

I think we should delete the 4096x2160p resolution from the whitelist, it is unnecessary on Amlogic boxes with CE. Always is a source of error.

I didn’t have it selected in the whitelist, but for some reason the default UI resolution was 4096x2160p.

Not sure at what point it changed to that, I certainly didn’t change it. Strange that it only happened after I rebooted the box though. Anyway, as long as I don’t use that resolution for the UI, it’s all good :slight_smile:

Thanks

It happened again!

Just switched my AVR over to the Kodi input and I had a tiny picture in the top corner of the screen.

Rebooted the box and had no signal. Connected directly to TV and checked settings and the GUI had changed back to 4096x2160p again!

I don’t have that resolution selected in my whitelist, but the GUI doesn’t respect the whitelist, it just uses whatever is selected as the GUI resolution.

This was never happening on previous versions.

Should I try the latest nightly?

The other weird thing is that the AVR is ok with 3820x2160p at 59.94, but directly to the TV I get no signal at that res/refresh rate. Something weird definitely going on.

Make sure Kodi’s GUI is set to 1080p. Whitelist all the resolutions your TV support except lower than 720p and higher than 3840x2160p. Since you have a LG C8, you probably should enable “Use 4:2:2 colour subsampling” when you are directly connected to your TV. Dunno if you should enable it when connected to your AVR. Try it out. In my case, my Onkyo AVR doesn’t support 4:2:2 10-bit, so I’ve to disable it in order to get 10-bit signal.

Just to be clear, your problem is that Kodi’s GUI changes every time you turn on your box? Or when you connect/disconnect to your LG TV? I’ve experienced some issues regarding the order when you power on the devices. Your TV and AVR should be powered on before your Kodi box.

You can easily try out nighlies by updating with tar, yet I doub’t there will be a difference

This is what I already had. Apart from I had the gui at 3840x2160p because it works and looks sharper :slight_smile:

I don’t want to use it connected directly to the TV, I only did it because it’s the only way I can see the settings once the AVR loses signal. I don’t have issues with my AVR with other devices like Xbox One X, PS4 Pro. Pretty sure my Xbox One X is set to 4:2:2 10 bit.

The original issue of no signal happened when I rebooted the Kodi box, it started booting then gets no signal after the CoreELEC logo. After lots of experimenting I discovered that the GUI setting had changed to 4096x2160p and the AVR doesn’t like it. I’ve been using this for months with no issue before.

The latest issue was that the picture on Kodi was a tiny image in the top corner of the screen, so I rebooted the box and the no signal issue happened again. Checked the settings and sure enough, the GUI had changed to 4096x2160p.

Like I said, been using this box for many months on this AVR and TV setup for many months without issue, so something strange going on.

Okey. I would recommend setting GUI to 1080p to make sure cs/ds switching work as expected and so you don’t have any issues regarding the GUI changing to 4096x2160p

So you’re saying that if I set the gui to 1080p it won’t try to switch to 4096x2160p but will when if I have it at 3840x2160?

What’s C2, I don’t have a C2, that is the OP :slight_smile:

I have a Tanix TX5 Pro and it definitely supports HDR10 :slight_smile:

Yeah, you should set GUI to 1080p and see if that solves it. I think it will :slight_smile:

Ok, thanks, I will if it happens again.

I set it to 3840x2160@60Hz, I also turned on 4:2:2. Rebooted it and it was still ok, so we’ll see!

Thanks for the help :slight_smile:

@chromium, You can also try this solution.


Don’t know if it works, but should…

Thanks, will give it a go next time I have issues

Maybe the solutions I have used can serve as a reference to make changes more adjusted to your preferences and your type of TV. I also had some problems with the video output (distortions and image instability and color distortions). I solved this by forcing a single resolution, without the possibility of selecting another one, from the start of my Mecool KIII Pro (S912) and modifying the Kodi system settings.

File /flash/config.ini:
hdmimode=‘720p50hz’ (Added 09172019: I have seen that this does not work and I no longer use it)

File /storage/.kodi/userdata/disp_cap:
720p50hz (does not allow another resolution)

File /storage/.config/autostart.sh
fw_setenv hdmimode 720p50hz (fixed startup resolution)
fw_setenv outputmode 720p50hz (fixed startup resolution)

Settings in Kodi->System->CoreELEC
Disable noise reduction: ON
Disable deinterlacing: ON
Limit display color depth to 8-bits: OFF (solves color distortion)
Use 4: 2: 2 color subsampling: OFF (solves color distortion)

1 Like