Plex add on crashing Kodi

The official Plex add-on is crashing Kodi. I’m making an assumption that it’s OpenELEC related as I dont see any such issue on the plex github project.

Basically randomly the UI freezes and Kodi then restarts after about 20 seconds. Looks like Kodi suffers a Segfault.

Hardware: X96MAX 2GB. Latest stable, 9.2.1.

Using host libthread_db library "/usr/lib/".
Core was generated by `/usr/lib/kodi/kodi.bin --standalone -fs'.
Program terminated with signal SIGSEGV, Segmentation fault.

It seems to be OK in 1080, but seems to be a problem on 4K. Perhaps scaling causes an issue?

This is a CoreElec forum.
Asuming you are actually referring to a CoreElec installation, here you will find some helpful tips on how to do a little legwork for yourself when you suspect there may be an issue / bug to report. :+1:

Oh yeah, CoreELEC, force of habit. Will follow those steps

Here you go:

This is a fresh install, Change res to 4k, and install plex client(from official repo) and set it up.

Play a few vids, when try to navigate some menus and BOOM.

Pity, it’s the only thing that’s spoiling ths setup. If you need any more info let me know.

Please read

2020-01-01 22:41:12.443 T:4060504080  NOTICE: Whitelist search for: width: 706, height: 480, fps: 23.976, 3D: false
2020-01-01 22:41:12.443 T:4060504080  NOTICE: Display resolution ADJUST : 4096x2160 @ 23.98 - Full Screen (39) (weight: 0.093)

Thanks for the tip, but after changing to 3840x2160 the problem persists.

Seems to be always after

2 00:07:27.172 T:3521115008   DEBUG: Thread Timer 3521115008 terminating
2020-01-02 00:07:27.207 T:4066508816   DEBUG: Keyboard: scancode: 0x01, sym: 0x001b, unicode: 0x001b, modifier: 0x0
2020-01-02 00:07:27.208 T:4066508816   DEBUG: HandleKey: escape (0xf01b) pressed, action is Back
2020-01-02 00:07:27.310 T:4066508816   DEBUG: Activating window ID: 13003
2020-01-02 00:07:27.310 T:4066508816   DEBUG: ------ Window Deinit (/storage/.kodi/addons/script.plex/resources/skins/Main/1080i/script-plex-posters.xml) ------
2020-01-02 00:07:27.310 T:4066508816   DEBUG: ------ Window Init (/storage/.kodi/addons/script.plex/resources/skins/Main/1080i/script-plex-blank.xml) ------

Tried Disabling CEC and GUI sounds. Still the same.

Use PlexKodiConnect instead of Plex add-on, much better.

Yeah, I tried that, but the size of my library took hours to sync, and content was missing, and it seems very buggy to me.

I’m gonna try the nightly of CoreELEC see I can still see this SIGSEGV.

Yea, nightly is reproducible also :frowning:

Anyone any ideas?

Thought I would chime in here since I just made the switch. I’ve been using the Plex Kodi plug-in for a couple of years now and indeed, it does crash Kodi, I really had to find an alternative. Also, the plug-in is not really maintained at all or it seems that way.
So, this weekend I switch to PKC. I had tried it in the past but it was very buggy and would crash my Minix U1. Well, things have changed and I can tell you that it is working very very well, Rocksolid actually!
Since I essentially just use Plex, PKC has won me over.

Did you know there’s a new Plex client add-on available in the Kodi repo? It’s called Composite and I’ve been impressed by it.

I can’t say I’ve had crashed with the official Plex add-on but I found that the player controls would sometimes be kept when I exited and went back to Kodi. It would also sometimes play hd video with 5.1 sound in blurry SD and with pcm stereo.

1 Like

Same exact thing for me.
Yesterday I tried the plug in you suggested
“Composite” it does work well also but I think I’m going to stay with PKC for the moment, give it a good once over. Thanks for the suggestion!
It’s nice to have alternatives that work!

FYI, Still a problem on 9.2.2 :frowning:

Same here. Only happens on the home screen and during a full library sync. If I quickly go to the add ons screens the sync will finish.

Hi mate. Reading through your posts, does it happen when you press the back button when you are in a movie page or library? For me it happens randomly when I press the back button and it freezes for a while and Kodi restarts. Which version of the plex add on are you using? 0.2.0 was released recently but I have not been using it as it gave me some issues with playback so I rolled back to 0.1.7

Yes that’s pretty much exactly what happens. I have been using the latest in the add-on store.

Yes the same thing happens with me on the older version. Hope someone can help deciphering the log entries.