No HDMI signal after CoreELEC splash screen

Okey. I would recommend setting GUI to 1080p to make sure cs/ds switching work as expected and so you don’t have any issues regarding the GUI changing to 4096x2160p

So you’re saying that if I set the gui to 1080p it won’t try to switch to 4096x2160p but will when if I have it at 3840x2160?

What’s C2, I don’t have a C2, that is the OP :slight_smile:

I have a Tanix TX5 Pro and it definitely supports HDR10 :slight_smile:

Yeah, you should set GUI to 1080p and see if that solves it. I think it will :slight_smile:

Ok, thanks, I will if it happens again.

I set it to 3840x2160@60Hz, I also turned on 4:2:2. Rebooted it and it was still ok, so we’ll see!

Thanks for the help :slight_smile:

@chromium, You can also try this solution.


Don’t know if it works, but should…

Thanks, will give it a go next time I have issues

Maybe the solutions I have used can serve as a reference to make changes more adjusted to your preferences and your type of TV. I also had some problems with the video output (distortions and image instability and color distortions). I solved this by forcing a single resolution, without the possibility of selecting another one, from the start of my Mecool KIII Pro (S912) and modifying the Kodi system settings.

File /flash/config.ini:
hdmimode=‘720p50hz’ (Added 09172019: I have seen that this does not work and I no longer use it)

File /storage/.kodi/userdata/disp_cap:
720p50hz (does not allow another resolution)

File /storage/.config/autostart.sh
fw_setenv hdmimode 720p50hz (fixed startup resolution)
fw_setenv outputmode 720p50hz (fixed startup resolution)

Settings in Kodi->System->CoreELEC
Disable noise reduction: ON
Disable deinterlacing: ON
Limit display color depth to 8-bits: OFF (solves color distortion)
Use 4: 2: 2 color subsampling: OFF (solves color distortion)

1 Like