No TV Adapter After reboot

i have KIII pro … After update last build i cant show internal dvbs2 in list device in tvheadend

i try again install driver dvb from addon coreelec and reinstall tvheadend … then reboot = i can see dvb s2 in list … but after reboot again issue come again


Try to clean TVH dvb adapters config:

systemctl stop service.tvheadend42
rm -rf /storage/.kodi/userdata/addon_data/service.tvheadend42/input/linuxdvb/adapters/
systemctl start service.tvheadend42

ya , i do that …
but after second reboot issue return

i note :
only restart service via ssh= working driver dvb
but if i reboot = not working

I think there is something wrong

Try after rm adapters config reboot box.

For me this doesn’t work.
Is it working for someone on Kiii Pro with LibreELEC Module drivers?

Boas also happen to me sometimes.
KI Pro Already for some time!
I tried a new installation in sd yesterday, but still the same thing happens.
All TV adapters disappear
in Tvheadend

After many unsuccessful reboots I succeeded.

Here I solved the installed problem:
The DVB drivers from the latest kernel (media_build)
I heard here in some topic of some members asking why they can not see signal quality and snr, here it was also impossible to see after the installation with you to see!

As seen here happens with DVB-S satellite.
Signal quality and snr will be seen again after a long time.

On a fresh install it works immediately.
But there are the CoreELEC Module drivers.
So are LibreELEC drivers not working for Kiii Pro and CoreELEC drivers do work?

Same problem here. After reboot no DVB device.

Disable then enable Crazycat drivers it works again every time.

Tronsmart Vega S95 Telos (S905), Hauppage PCTV 292e Triplestick

ok Thanks for the suggestion.

Backup - Fresh Install - Restore worked for me.

How did you make the backup?
Here I thought I had posted my solution, but again, what I did:

  1. Fresh install on SD > tuner working
  2. Move everything in HDD except “recordings” to a new subfolder “_bak”
  3. Copy everything from SD to HDD
  4. Copy everything from “_bak” to HDD, except /storage/.kodi/userdata/addon_data/service.tvheadend42 (and in my case pvr.hts and pvr.hts2)
  5. Copy /storage/.kodi/userdata/addon_data/service.tvheadend42/dvr from “_bak” to HDD to have the recordings
  6. Create an empty user in tvheadend to show all the recordings in Kodi
    The drivers aren’t the problem

CoreELEC addon in System (cog at the homescreen then CoreELEC)

Astrometa DVBT2 + Odroid C2… (8.99.2):

  • Default CE DVB drivers- my DVB2 tuner isnt recognized
  • CrazyCAT - tuner is recognized, but tuning is bad, cant get even stream to play. Signal strength status is visible.
  • media_build - tuner is recognized, continuity error shown sometimes, but only minor appearances (1 from the start etc.). Signal strenght status is not visible, but playing - tuning is working just OK :wink: (need more testing/watching time)

So I dont care about not showing signal status, as you can see, thing with drivers are very gimmicky, so if you find stable and working driver for your tuner, its great :slight_smile:

No missing TV Adapter after reboot (ssh/gracefull from GUI) on C2+8.99.2. Next update I can do after some weeks, when I visit my parents again, could report latest 9.0 (In my appartment I am using router+DVBT2 stick as DVB-T/T2 source, streaming signal to CE) - more likely there will be another CE release before I would be able test DVB+CE again, with Kodi 18.1

Hi guys, I am having a TV adapter issue but not exactly the same as above. I also have a KIII Pro with the AVL6862 card and it is working fine. My issue is that I also have two other tuners in the USB ports. A PCTV 461e (DVB-S2) and a PCTV 292e (DVB-T2) but only the PCTV 461e is being detected. The PCTV 292e is detected in LSUSB but it does not show up in /dev/dvb. The AVL6862 and PCTV 461e show up in /dev/dvb as adapter0 and adapter1 respectively. Any idea why the 292e is not detected correctly?

Only Crazycat drivers work for my 292e. Media Build drivers don’t.

issue return after update to 9.0
i think must reinstall system again

@Daave Thanks very much. I found them in the CoreELEC Drve Conf addon and they detected mine also

1 Like

just set a 5 seconds delay to TVheadEnd server start, it works for me :slight_smile: