No wired connection on Pendoo T95z Plus [S912 - 8.90.2]

Hi everyone,

This is the device I’m talking about: T95z Plus
It has a Amlogic S912 Octa-Core ARM Cortex-A53 64-bit 2GHz.

cat /proc/device-tree/amlogic-dt-id

The original device tree can be found here: dtb.img.gz

I have tried all device trees with mixed success:
gxm_kvim2.dtb boots, wireless ok, but wired doesn’t work
gxm_q200_1.5g doesn’t boot
gxm_q200_1g doesn’t boot
gxm_q200_2g boots, wireless ok, wired no ip (1000mbps)
gxm_q200_2g_minix_neo_u9 boots very slow, wireless ok, wired no ip (1000mbps)
gxm_q200_3g doesn’t boot
gxm_q200_k3_pro doesn’t boot
gxm_q201_1g doesn’t boot
gxm_q201_2g boots, wireless ok, but wired doesn’t work
gxm_q201_3g doesn’t boot

Even if I use the original device tree, it boots but the wired network is not working.

If I check the wired connection in Android, it’s reported as 1000 mbps, so it’s not a cable or switch issue.

Where can I find a working device tree?



look here

I tried but the wired network is still not working.

Try gxm_q200_2g and execute via ssh: ethtool -s eth0 speed 100 duplex full
Did you test it under android if is it really 1Gb? And what info is on your router about this link?

Strange, there is something wrong here.
the dump your original dtb tells me the following:
~/DTB$ fdtdump gxm_q201_2g.dtb | grep amlogic-dt-id*
amlogic-dt-id = “gxm_q201_2g”;
Where did you get this file from?
please create dump from dtb partition

dd if=/dev/dtb | gzip > /flash/dtb_orig.img.gz

The original device tree can be found here: dtb.img.gz
This was taken from the dtb partition in Android.

How does it come that amlogic-dt-id reports something else (in Android)?
cat /proc/device-tree/amlogic-dt-id

You can’t just boot any device tree and expect it to work.

gxm_q201_2g should be what you should be using.

You will need a custom DTB for your LAN, the issue is the GPIO setup on your device is different because of the display on the front, we have seen this with other devices.

I don’t really like creating device specific DTBs as it makes things even more confusing adding another to the never ending list of them.

1 Like

I understand that’s too much work to maintain DTB’s for all different kind of devices.

How can I create a custom DTB that works with CE? How can I convert an Android DTB to a CoreElec DTB?
Some kind of manual/instructions would be appreciated because I’m probably not the only one who faces this problem.

You can’t convert DTBs they are specific to the kernel that they was compiled against.

It’s not the kind of thing I nor anyone else can provide a manual or instructions for I’m afraid, if you was an experienced Linux user you may be able to hack one of the current ones to work, it would be far easier to send it back and get one that is known to work.

Any update on this?

I have also a T95Z Plus with same problem but I have the 3GB/32GB variant.

With Coreelec 8.90.3 I have tried the following:

gxm_q200_3g.dtb: Wifi works, Ethernet appears but gets no ip address

gxm_q201_3g.dtb: Wifi works, Ethernet does no even appear as an interface option

I also found a dtb posted on the forums called: “gxm_q201_3g_1gbit.dtb” which also did not get an IP from my router

I have use iperf3 under Android to verify that it is a 1GB ethernet port.

EDIT: I just opened my box, Ethernet is provided my a ZTE ZX2AA500 which is listed as “Gigabit Ethernet transceiver”

See here:

I just bought another box. Mecool M8S Pro W. It has only a 100mbps NIC but it works.

Is there any tree that works for the T95Z Plus and 1GB ethernet ?

The 1Gbit tree. If it doesn’t work, then at this point, there’s no solution.