Odroid C2 - CoreELEC 8.95.0 - No Internet


I’ve installed a clean copy of CoreELEC 8.95.0 to my emmc module on my Odroid C2 and I cannot seem to access the internet from within Kodi. I can access my local network and media shares, but nothing on the outside world. As a result I cannot access any Kodi repositories or update anything. I couldn’t even paste/upload a log file from within Kodi!

I’m connected to the internet via an ethernet cable.

So wondering if its something with this build I installed a nightly build too, but unfortunately have the same issue. This is my Kodi log:

CoreELEC 8.95.0:

I was previously running LibreELEC-Odroid_C2.aarch64-8.2.5.img.gz, so I decided to try going back to this build to check its not something with my C2, so I performed a clean install of 8.2.5 and everything works fine out the box. All repos are accessible and everything updates correctly. Really strange!

Now back on CoreELEC 8.95.0 I’ve tried Curl from within SSH and that works fine, so it seems to be a Kodi issue?

Can anyone please help? I’ve been scratching my head for many many hours now! Thank you in advance.

From log you have devel version, not 8.95.0. Try to install release 8.95.0

Yes, I mentioned that in the description - same problem on both 8.95.0 and the latest nightly build. Log is from the latest nightly.

Edit: I’ve added a 8.95.0 log to original post

Has to be a clean install. You can’t upgrade from LE OS

Try to ping, if it works, than your dns doesn’t work
Try to switch firewall to off
Try to use manual IP settings…
Also check on you router if it has any related events

Thanks for your suggestions.

/etc/resolv.conf has

I can those ping IP’s, so DNS is working fine.

I had a thought to try a VPN but when I wget or curl
wget https://github.com/brianhornsby/script.openvpn/releases/download/v3.0.0/script.openvpn-3.0.0.zip
Connecting to http://github.com/ (
wget: error getting response: Connection reset by peer

This works fine from my mac on the same network.

tried using wget --no-check-certificate too

Sorry had to split this over two posts due to a 2 link restriction

This however wget https://google.com works fine.

iptables -L -v

Doesn’t have any entries

Also nothing weird going on in the hosts file

I haven’t got a firewall on my router side. Is there one in CoreElec or Kodi other than iptables?

Again, this is all from a clean install. Only thing I’ve done is accept the initial options on the welcome screen and enable debugging.

Is anyone else with and Odroid c2 and a clean install able to replicate any of this?

CoreElec settings->Network->Firewall
You can also try to use your provider dns or remove and try without it

Firewall was off by default, and I tried it set to Home and Public and no change, still no response to any addons.

Tried removing and no change when using wget the openvpn addon
without any namesever entry and I do a wget:
wget: bad address ‘github.com

If you can ping google and the DNS IP servers, this sounds like your DNS isn’t working.

Couple examples of what seems like the DNS resolving correctly:
It doesn’t let me post these here so dumped them:

I installed 8.95.1 today and now everything is working as expected. :smiley: