Odroid C2 random black screen (blink)

Running Coreelec 9.0.1 9.0.2 or Nightly june 9th, I experienced regular black screen blinking not only when viewing video but also in GUI.
It looks random, but when it starts blinking (random frequency) it stops only after reboot.
For example, I have watched TV and after 3 hours the screen started to blink. I have restarted and up to now it works.
What can I do to troubleshoot ???
my kodi log is there http://dl.free.fr/mFZe0BvOB

Thanks for your help

Same today after 10 min watching TV and a brand new Amazon basics HDMI 2.0 cable.

Can you ssh into the device and run the dispinfo command then post the link it provides here.

As requested.

Can you remove the echo 5 > /sys/class/mpgpu/cur_freq line from your autostart.sh and let me know if you still have the problem after that.

What you describe looks like what my C2 used to do while having a bunch of peripherals connected to it.
Have you tried an another power supply? Something which is really able to provide up to 2A?

I’ve found with most of these inexpensive power supplies you need to pad the rating a good amount. So if you want to be able to deliver 2A reliably, you need one rated for 3A. I’ve had cheap 2A rated supplies fail instantly when driven up to a 2A load. Though not a problem with quality supplies, if they’re rated for some amount they can deliver it without issue.

I have the power supply sold by hardkernel and I only have a RF receiver plugged into USB (for my remote) - no HDD as I have attached my NAS through NFS. WiFi and BT are deactivated.

I have deleted my autostart.sh and I will test tonight.

Thank you all for your advices.

Hello everyone, unfortunately still the same issue when I remove my autostart.sh with GPU overclock.