ODROID C4 suddenly stopped to send video signal

I was a happy user of CoreELEC 9.2.4.2 for over a month, but suddenly my TV loses video signal right after I start any video which played well before. Surprisingly i can hear the sound which stutters.

My setup:

ODROID C4 and CoreELEC 9.2.4.2
Denon AVR-X1600H
Samsung QE65Q70RATXXH

I was able to listen to Atmos/TrueHD audio in the above configuration.

What I was trying to make a diagnosis?
On my AV Reciever I reset to factory defaults and tried to connect ODROID on other HDMI input, doesn’t help.
Created SD card with a fresh install of CoreELEC, doesn’t help.
Reconnect ODROID to one of the TV HDMI inputs, it helped but my TV can send audio to my AV Reciever only as PCM. I can’t listen Atmos/TrueHD audio any more. Sometimes my ODROID is detected as OrangeTV device by my TV.
PS4 connected to AV reciever works fine and I can listen to DTS audio.

cec_osd_name=‘CoreELEC’
CoreELEC is visible only by AV Reciever, on TV i have to set ODROID as PC device to be able to use Samsung remote controler with Kodi.

How can I fix that issue and listen Atmos/TrueHD audio through my AV Reciever, again?

Is there any specific logs on CoreELEC which could help to resolve that issue?
I am not an expert on CoreELEC, any help would be appreciated.

I did one more test. MacBook with Kodi installed and configured for pass-through plays all my video files as it should be played.
4K and DTS is properly recognized by Denon AV receiver.

How can I find what is wrong with my ODROID C4 device then?

Solved my issue finally.
My HDMI cable connecting TV and AV receiver was faulty.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice