Odroid N2 and WD external hdd not recognized


Using CoreElec 9.2.3 on a Odroid N2 4Gb CoreELEC edition unit. I have 2 external and self powered USB HDDs connected to it via USB. Both are WD external HDDs, one is a MyBook Elements 3Tb and the other is a similar unit with a capacity of 640 Gb.

The problem I have since the beginning (even with CE 9.2.2): very frequently, the 3 Tb WD HDD is not connecting and not recognised by the N2. The 640Gb one is always connected and recognized. Even when rebooting the unit, very often, the 3Tb is not seen and won’t connect. Tried changing USB ports, etc. no change. The 3 Tb HDD is working fine when connected on a Windows PC.

Even when I disconnect the 640 Gb, still the same. Approx. 8 times out of 10, the 3 TB HDD is not seen by the N2 when booting the unit. Also tried another power supply for the N2 unit just in case (even if both HDDs are self powered and have their own power supplies).

Any ideas or pointers would be greatly appreciated. Thanks

Try connect to linux computer. Microsoft have new table GPT for bigger hdd, which is not compatible for other system sometimes. I have 3 tb hdd, where is partition msdos MBR table. I dont have issue under linux, windows, android, and coreeelc on old Mecool KI Pro.

1 Like

Thanks for the reply. The 3 Tb drive does work and is seen sometimes by the Odroid N2, but not always. I guess that if there was any incompatibilities with the GPT table on CoreElec, the drive would never connect to the N2. It does works sometimes, but mostly it does not.

My expereience is that these SBC often have underpowered USB sockets which makes power hungry peripherals not get detected or frequently disconnect in use. The best solution is to use a powered hub to ensure that the peripherals get adequate power.
Also quite often not all the USB sockets are made equal and one may work fine with a HDD but another is erratic.


Thanks Shoog. Have you noticed this behavior even when the external HDDs have their own power supplies ? Both my external HDDs are “desktop” type, and do have supplies of their own. Guess I should try a powered hub anyhow.

But I recall seeing something about some WD external HDDs not coming out of “sleep” with SBCs , but cannot find it anymore.

PS: sorry if there are typos or grammatical errors in my posts, since english is not my native language.

If they are powered HDD then they shouldn’t have power issues, but it is worth switching them round on the USB port as I have seen people reporting issues with some of the USB sockets on the N2.

i can’t comment on WD external disks as I have SEAGATE myself and use UGREEN caddy’s.


When I boot or reboot the N2, the HDD is not seen or recognised frequently. However, if COreElec is running, and I unplug / replug the USB connector, then the HDD is immediatly recognised and mounted. Strange behavior indeed.

Sounds as if the HDD is sleeping when the boot is probing the USB’s at boot.
There is a setting in Coreelec settings addon under hardware to keep USB alive when power is off, try switching that to on and see if it makes any difference.

If my system has a power cycle most of the time I have to press the ON button on my UGREEN HDD caddys to wake them up again. This is a very good reason to leave my VIM2 server box on 24/7, and the power usage is insignificant. I also consider switching my box on and off as the most likely event to cause a system failure.


Thanks Shoog. I’m pretty sure that’s the issue, the HDD is sleeping when the unit is probing the USB ports at boot time. Since that HDD has a large number of files, the time it takes when it wakes up and starts is probably too long for the N2 to see it when booting, so it won’t mount at that time. That’s my theory , i’m probably wrong.

I did try the “keep USB alive” setting to on, but it does not change anything, issue still remains. Funny thing is that the 640 Gb HDD is a similar WD self powered unit, and it doesn’t have the same issue than the 3Tb one. I too leave I leave the Odroid N2 / CoreElec always on. At least the 3tb hdd wakes up when USB is unplugged and repluged after a reboot.

Thanks for the input and comments, appreciated !!