ODroid N2 Bluetooth Won't Auto Reconnect After Reboot

So I’ve seen previous threads about this and I’ve read through as many as I could find, but I don’t see any that speak to this specifically. After pairing my Odroid N2 and my Harmony remote via the generic Bluetooth dongle sold by Ameridroid, the pairing fails to reconnect after rebooting.

I’ve tried using an autostart.sh solution found in other threads. No luck.

Is there a solution to this?

Hi @Newoski, I had the same problem with a Harmony Hub before and used this:

# /storage/.config/system.d/harmony.service
[Unit]
Description=Connect to Harmony on BT on startup and resume
After=suspend.target bluetooth.service

[Service]
Type=oneshot
ExecStart=/usr/bin/sh -c "for i in 1 2 3 4 5; do if bluetoothctl connect 00:04:20:F4:F1:22; then exit; else if [ $i -eq 5 ]; then exit $?; else sleep 5; fi; fi; done"
TimeoutSec=0

[Install]
WantedBy=multi-user.target sleep.target

But it seems to do be doing fine without it for a while now (I’m at 9.2.0 on a generic S905X2 box with an external BT dongle).

UPDATE:

I’m very happy to report that switching to a different Bluetooth dongle seems to have solved the problem. I just grabbed a MediaLink BT dongle that I had sitting around, swapped it out, and it worked first try.

Thanks for the reply. Sadly, no go on my system. I did the following:

Created /storage/.config/system.d/harmony.service
then
chmod a+x /storage/.config/system.d/harmony.service
then
Added contents you shared with my bluetooth address

Is that right? Which dongle are you using? Do you know a model?

FWIW this was wrong, the right way to enable the systemd service is using systemctl:

systemctl enable harmony.service
1 Like