ODROID N2+ install

Evening, folks. After many years of flawless performance from Libreelec, my Nuc finally died. I purchased an Odroid N2+ and am having a very hard time installing CE. I tried burning CoreELEC-Amlogic-ng.arm-19.0-Matrix-Generic.img with both Etcher and Rufus, on both a USB and SD card, with no luck. It’s not clear if I need to move/rename the appropriate dtb.img file, so I tried that both ways as well.

The Odroid can see the device each time in petitboot, but I don’t seem to be able to boot from it no matter what switch I flip or what settings I apply in the config. What am I missing here?

Just guessing but I think you need to use the Odroid N2 image and not the generic. At least that works for me.

Thanks, I’ll try it next. I followed the "Download Helper"s recommendation, which was the Generic build (generic 9.2.7 was a swing and miss, too).

The download helper clear point out to Odroid_N2.img.gz files. Both on 9.2.7 and CE-19!

I saw S922X listed first and stopped scrolling. N2+ image seems to be working fine so far. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice