Odroid N2 MCE Remote problem

Hi, I just got new Odroid N2 and I’ve transfered all the settings from my old H96pro+ 3/32gb (backup and restore).
I’m using MCE remote wich worked fine on H96Pro+, but on N2 it stops responding after 2-3-4 commands and I have to wait for about a minute before it starts to respond again to IR commands. While it does not respond the IR commands CE is responding without any problems to commands from CEC or wireless keyboard/mouse.
Do anyone have any ideas where the problem might be.
Other than that CE accepts all the commands from the remote as it should (custom lircmap and remote keymap in kodi).

I saw something interesting. In kodi menus/library navigation the remote does not work and irw does not show any received commands. While playing video however the remote is working OK and irw shows received command

# irw
77 0 KEY_PAUSE devinput
77 1 KEY_PAUSE devinput

My config is here http://ix.io/1Y6Z

On my N2 the MCE remote I have doesn’t work.
Followed a lot of the guidance about media drivers and removing the rc-config file but doesn’t help.

Any clues.


There is something very wrong with Odroid-N2 IR receiver.
For me it “worked” right out of the box after a clean install of CE without any modifications to config files.
I’ve tested with CE nightly and the problem is still there for me - after a few commands the menus become unresponsive, the box stops receiving ir commands.
I “solved” my issue by masking internal Odroid IR receiver with some electrical tape and using USB MCE IR receiver that I have laying around from my ION-330 days.
Also with external receiver I do not have to point the remote directly to the receiver in order for it to register the command (while it is working).

Is there any more elegant way to disable the internal ordroid-n2 receiver without disabling meson-ir?