Odroid N2 Playback Issue Since 9.2.2

Hi,

Since the 9.2.2 builds (and including the latest nightly) I’ve been having issues with playback of certain recordings from BBC1 HD from UK Freeview. The same recordings playback flawlessly on 9.2.1 and within all other players i’ve tried. It’s only certain programmes that it happens on and it happens with every episode, so I think it’s something to do with the broadcast format, rather than a single bad recording.

I’ve uploaded a sample here.

For reference at around 7 seconds and 10 seconds the video freezes with the audio continuing, at around 17 and 38 seconds it glitches and shows broken up. These issues continue throughout the short sample.

The debug logs are here.

Can anyone else confirm that this happens for them?

Thanks

At 00:07 the video switch from progressive to interlaced. I tried that sample on my Le Potato (ng build) and I also see this issue.
On my Intel J4105 LibreELEC box it plays fine.

I too have problems with certain H264 Freeview UK HD streams, most notably during news programs but not exclusively. The symptoms you describe are very similar to mine. I have reverted to 9.2.1 which seems to be glitch free as you’ve noted.

I know that the CoreELEC team are aware of this problem because I’ve privately shared video samples and that it’s on the to do list, the cause being an “Amlogic h264 code bug” for which “simple magic doesn’t work”. I can’t tell you anything beyond that.

Perhaps it’s time for the CoreELEC team to comment publicly on the issue.

Perhaps it’s time for You to slow down and be patient.

1 Like

Not fair Tim. It was a long process to identify but it’s been nailed down since 11th May. I am more than prepared to wait and have only posted about the problem and have not pushed anyone to force a resolution. I put this because my dealings with developer have been private and someone else with the problem has come along and needed to be aware of the situation imho.

2 Likes

Really ?
CE devs are working in their freetime.
A little gratitude would be appropriate.

CE is not commercial

Have a good day but please try to get your facts straight before throwing stones. I will not argue with you.

2 Likes

I can confirm the issue with the clip as described by @TTTGary and welcome to the forums too btw.
It does play correctly on any Windows x86 platform.

If I turn off hardware acceleration then there is some improvement but not enough to be happy with.

I’m guessing that TVHeadend us being used to configure recordings?

If so, then I wonder if, in the short term at least, it is worth changing the stream profile for recording to another option to see if the output is more acceptable.

I regularly record Match of the Day/2 in HD using the matroska profile and have not to date encountered the same issue myself with any release and I tend to use every nightly coming out.

It is good that something has been identified before, with samples having being shared and discussion taken place and patience is required to allow things to happen in the background.

The fact that so far, only 2 people have reported the issue(that I can see) since early May does seem to indicate that this is not a wide scale issue and therefore, quite understandably, would not be top of any fix list and from my experience, when there is a solution to an issue, you can bet that the team will publicise it. Until then, if there is no solution and the issue has been identified, any open forum discussion would not realistically have any benefit for anybody, save for any new reports that the team are not already aware of.

@Tim_Taylor is correct to remind us that a lot of work is done in free time and for free and so never a bad thing to take a little step back from what might at times feel a little frustrated to know just how much benefit we get from CE and all that goes into it.

If only the people that we purchase the boxes and SBC’s from put in the same amount of effort in as the CE team does, particularly when vendors are not doing things for free but for profit.

I will fall on my sword for the benefit of the community. For the record, I sincerely hope that I have never left any developer thinking that I was not appreciative of their efforts. If I have, I apologise. In my mind, I have been trying to assist in taking CoreELEC forward for all.

If, by suggesting a formal acknowledgement, I’ve created the impression of pressure on the developers, that was not my intent. I was just thinking of transparency for users. For them, the non Ng variant works on lower spec equipment as does the Ng 9.2.1.

I think we should lift this emotional discussion back to a technical one. I don’t think anyone’s feelings were hurt.

1 Like

A post was merged into an existing topic: ODROID-N2 CoreELEC Edition!

I’ve also noticed this.

Mostly on itv hd, uk freeview. Rolling back to 9.2.1 solved it. So much so I forgot it was a issue.

N2, using the hdhomerun pvr addon, im pretty sure it was only on recordings. Not on live.

Issue doesn’t appear to be present on my s912 box running the latest stable version.

Matt

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice