Odroid N2+ Power On/Off issues

I using a Sony Play TV as the tuner (works well).

TV is a Sony with CEC support.

From a cold start everything works fine. The TV remote turns on the N2 (I presume via CEC).

But the the N2 will only turn off via the TV if nothing is playing. This means manually stopping playback before attempting to turn off.

I don’t mind the N2+ staying on as it’s low power but when turning the TV back on I only ever get a black screen. Not sure if the N2 has frozen but I need to remove the power to get things working again.

Also if the TV is turned on by another device (my PS3, PS4 or internal TV tuner) the N2 also receives a signal to wake up (no problem) but if I later change input source over to the N2 it is always a black screen (and again only power cycling will fix).

So I am constantly having to pull the power on the N2.

Any ideas or tips appreciated.

Hi Wally,

I have a C4, so may use similar settings. My C4 is only the frontend, using a separate mythtv backend. It turns off whe turn TV off, and on when TV on. If something was playing when I turn off it resumes when turn on. Takes about 15s to turn on though.

There is a parameter in Settings/System/Input/Peripherals/CEC Adapter for making playback pause when turn off. When I setup my C4 some time ago I played with some settings here until I got CEC to work how I wanted it. My resultant The settings from /storage/.kodi/userdata/peripheral_data/cec_CEC_Adapter.xml are shown below.

Maybe need to specify video mode vout in /flash/config.ini to match your TV?

<setting id="activate_source" value="0" />
<setting id="button_release_delay_ms" value="0" />
<setting id="button_repeat_rate_ms" value="0" />
<setting id="cec_standby_screensaver" value="0" />
<setting id="cec_standby_screensaver_paused" value="0" />
<setting id="cec_wake_screensaver" value="0" />
<setting id="device_name" value="CoreELEC" />
<setting id="device_type" value="36051" />
<setting id="double_tap_timeout_ms" value="300" />
<setting id="enabled" value="1" />
<setting id="pause_or_stop_playback_on_deactivate" value="36045" />
<setting id="pause_playback_on_deactivate" value="0" />
<setting id="physical_address" value="0" />
<setting id="power_avr_on_as" value="0" />
<setting id="screensaver_delay_standby" value="0" />
<setting id="send_inactive_source" value="1" />
<setting id="standby_devices" value="36037" />
<setting id="standby_devices_advanced" value="" />
<setting id="standby_pc_on_tv_standby" value="13011" />
<setting id="standby_tv_on_pc_standby" value="1" />
<setting id="tv_vendor" value="0" />
<setting id="use_tv_menu_language" value="0" />
<setting id="wake_devices" value="36037" />
<setting id="wake_devices_advanced" value="" />
<setting id="wakeup_cec_active_route" value="1" />
<setting id="wakeup_cec_auto_power" value="1" />
<setting id="wakeup_cec_streaming" value="1" />

Thanks.

I tried setting the vout. It already had a commented entry for 1080p 60hz and so I just uncommented that line.

After a reboot there was no change of behaviour.

I didn’t try playing with the CEC settings as most of the settings don’t mean anything to me.

I see the same behavior on an Odroid N2+ and Samsung TV.

I had also many troubles with my Odroid N2+ and a Sony 65XH9505 and a LG DS80QY Soundbar and everytime i switched form Receiver to Kodi the ARC breaks up. Soundbar didnt turn of or it moves to TV audio again. or the TV didnt turn of etc etc. also everything in CEC settings was off.

So somehow the Odroid stil sends a signal even trough everything was turned off.

Now this was the solution for me!!!

An Adapter to turn off CEC of the HDMI output.

https://www.amazon.de/CY-Ferngesteuerter-ARC-Funktion-HDCP-konforme-Unterstützung/dp/B0CLDMCV6B/ref=sr_1_4?__mk_de_DE=ÅMÅŽÕÑ&crid=2N1JGN7QTADIC&keywords=hdmi+cec+less&qid=1706372003&s=ce-de&sprefix=hdm+i+cec+less%2Celectronics%2C61&sr=1-4

Everything oke now since i only need the Passtrough Audio and Video, Remote Control is going over Yatse android Remote
Atmos True HD HDR10 and everything else works like a charm.
no problems anymore here!