Odroid N2 Suspend mode

quite a few things. Let me unplug everything else and try.

Not sure what uart log is but will google

You need a UART-USB adapter for your N2 to get uart log.

oh boy - more crazy shipping charges :frowning:
Didn’t get a chance to disconnect everything and try but will do so tonight.

Appreciated all your advice/help chaps!

Most cheapo UART adapters from ebay or aliexpress will do the job.

cheers - will look

I used to have this device and i remember that to wake the N2 from suspend i had to turn on my TV and switch HDMI source from the N2 to another HDMI source then back to the HDMI source the N2 was on. It would always wake from suspend when i did that.

It’s almost same on my LG, if have to select on the TV the HDMI port where the N2 is connected (ODROID-N2). Then it wake up.
This is TV brand & type dependent.

Thanks guys, but the problem is that the N2 actually shuts down. So nothing is going to wake it apart from a power cycle.

Actually, I think I know what the problem may be - or at least have a workaround. My Kodi is set to ‘Shutdown’ in Power settings. I reckon setting it to Suspend will sort. Will try when i get home.

Hmm, must take a look at my power settings, but my N2 suspends and wakes up via IR command just as it should…

How can you tell it shuts down, rather than goes into standby?

On shutdown you will see the CE Logo on restart, on suspend resume it enter Kodi direct.

If he unplug the power because he cannot wake it up then he cannot tell which was the case…

I ssh’d in and the putyy session dies.

Anyways, good news is that I know what it is. I was trying out one of the above suggestions to unplug everything from the TV and, cutting a long story short, I have an EGreat Audii/video splitter between the N2 & TV and that is causing the N2 to shutdown when TV is switched off. I connected the N2 directly to the Tv and all good - goes into Suspend and wakes up.

Pretty sure I tried that yday too but must have got something wrong. The EGreat is a bit problematic so will switch to an HDFury Integral next - more expense. Sigh.

Thank you all, once again.

And, apologies for wasting everyone’s time :frowning:

1 Like

Opening this one up again.

So before I splashed out on an HDFury Integral, i thought I would check if the N2 Shutdown/Suspend issue worked if connected through another device. So plugged it into my LG Home Theatre/BluRay combo and same issue.

The N2 shuts down instead of suspend and only way to wake it is to power cycle. Its all good connected directly to the TV - suspends and wakes up perfectly.

My Vero 4K+ and RPi3 both suspend/wakeup when connected through another CEC device like EGreat so this has got to be something particular to N2 right? Sadly, I gave away my S912 CE box so can’t test with that to narrow down to N2 or CE.

How can i check if N2 is really shutting down or actually suspending (but not waking up)?

Anyone please?

I plugged in the Vero 4K+ remote to test but even that does not wake it so suspect it is actually shutdown.

fyi, if anyone is still interested, Kodi debug log shows that Kodi/N2 goes into (correctly) Suspend mode (OnSleep messages) when TV is switched off.

So looks like a wakeup issue when plugged in through Receiver or HDMI splitter.

Kinda stuck now :frowning:

I told you somewhere that you need to make a UART log. You will need a UART adapter for Odroid. We have lot of users using a AVR what having problems with wake up. This is a issue by the hardware setup/brand/type of AVR and may solved never. The only way would be to exchange the AVR to a another one supporting CEC pass through also for wake up.

Noted. Figured that because both my EGreat & AVR were showing the issue it was not relayed to them.

Edit : also assumed N2 issue as both my Vero 4K+ and RPi3 (OSMC) suspend and wakeup correctly through EGreat etc.

Will di the UART thing.


I have very similar issue. CEC does not work, I cannot wake it up through LAN either (using Yaste) does not react to SSH and IR does not work at all. Pulling cable out and putting it back in is the only solution for me so far. Using Denon X1200W. Yet, it works the other way round, when I turn on my N2, Denon wakes up. I dont know what to try next.

Everybody with a wake up issue tried it also directly connected to the TV?
Without AVR!

If it is working directly connected to the TV it’s a AVR issue and we can’t help to resolve it.
You will need to search the internet which AVR is supporting the CEC pass through even when switched off.

For more support on CEC wake up a UART log is needed. A Kodi or dmesg log will not help.