Odroid N2 - System time/rtc not updating

Hi,
I have a Ordroid N2 running CoreELEC. The N2 recently updated to 19.2 RC2 and the system time is not being updated. I have set the correct regional settings but still no luck.
In addition to the clock issue I can not install any addons from the coreELEC or Kodi repositories.
Any help would be appreciated
Thanks
kip
Edit - I also have an Odroid C4 that is running 19.2 RC2 with no problems at all

Have you checked system info to make sure you’re connected to the internet? The symptoms you describe point to that being the cause.

I experience this issue on my Odroid-C2 as well: date and time are randomly set when an unexpected reboot is happening due to power outage.
Of course C2 is connected to my LAN and I have tried to specify as a time source some ntp URLs from List of Top Public Time Servers · GitHub but always when unexpected reboot happen date and time are wrong.
Then when I reboot C2 from Kodi menu date and time are back to correct one.
Don’t know if you are seeing your time wrong on your N2 due to power outage but just wanted to share my issue.

Did you install a CR2032 battery? If you didn’t, the time in the RTC will be reset after a power loss, but it should still correct itself during boot, if there’s a connection to the internet.
Maybe CE boots faster than your router does, and when it tries to query the NTP server, the internet isn’t working yet, and so the time remains wrong.

For what it’s worth, I don’t have the time problem on my N2 (no battery and running from eemc). I do have a time set for wait on Lan tho. I can’t say how long because I’m not at home.

Is your response for my post about time lost in C2 after power outage?
As far as I know there is no RTC backup battery for C2.
This is what I have found only: Odroid RTC Backup Battery where it is clearly stated it is not for C2: “NB: this product is not compatible with ODROID C2”

There is an RTC shield for the C2. I can get from my local supplier here in the UK. Please see the link below:

https://www.odroid.co.uk/rtc-shield-for-odroid-c2

OK, thanks for letting me know it is available… I wasn’t aware.
I have found it in my country as well, but I need to order it first and wait 10 days :slight_smile:

Yep, connected to the internet. Tried both wireless & wired. SSH’d into the box to test

Thanks, Sonofdibnah. I’ll look into that.
I tried using hwclock to set the date/time but it looks like the command is a cut down version in coreelec

Yes, but I thought you also had the same issue with an N2, sorry that my answer made no sense.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice