Odroid N2 test builds

seems like a problem with init7 iptv / my router. i am also unable to watch tv on my pc. thanks for the archive link.

Hi,

I’m not sure where the problem is, but with last few nightlies (since early October, I guess) I have issues with CEC.

My N2 is always ON 24/7. But when I turned on the TV, N2 is missing from the TV input selection option. Worst part is, it also breaks CEC of other inputs as well (also ARC). Kinda similar to CEC standby issue with S912 box. This problem gone if I unplugged N2’s HDMI.

So I came back to stable release 9.2.0 and everything is back to normal.

My system is Sony TV (ARC) - Denon AVR - N2/Shield/FTVStick (all plugged in to AVR)

Hello. With the last few nightly images, wake on lan not working for me.Can anyone confirm or the problem is with me.

+1 Confirmed. And it stopped after the last two or three nightly updates…

I can confirm this bug. Sony TV with Pioneer AVR. Odroid 24/7 on. Black Screen, but i can hear the Kodi menu sounds. Need to reboot the odroid so solve the problem.

I have a problem with stuttering on some 4K HDR movies (stable or nightly Coreelec, no matter). There is no problem in the unofficial ATV ROM LineageOS 16 and KODI 18.4 installed. Need some logs or something? If yes tell me how i can generate logs?

EDIT: Ok here is log with reproduced stuttering http://ix.io/1ZKj

I have the problem that all 4K videos hang up at about 30min play time. The UI is still responsive. But. I can’t resume or stop the video. I have to reboot. Any ideas?

I think I have found the issue. Sonos was connected at the same switch and caused the playback to stop. After disconnecting Sonos everything is fine now.

Just rebooted for latest update and result is “no systemd”, “kernel panic” and a bootloop. Anyone else?

Edit: never mind, I see this being discussed in the nightly thread. Sounds like a bit of a pain to fix. I think this might be a good point for me to step off to stable…

@Crusio, if you seek +10/30 or -10/30 seconds etc, does it solve the stuttering for the playback? Which movies?

@ CI6N0Z Yeah seek ±10 seconds solve stuttering. I have this in:

  • Alita.Battle.Angel.2019.2160p.UHD.BluRay.X265.10bit.HDR.TrueHD.7.1.Atmos-TERMiNAL
  • Brightburn.2019.2160p.UHD.BluRay.X265.10bit.HDR.TrueHD.7.1.Atmos-TERMiNAL

But i downloaded a remuxed version (not a rip version) of Alita and there is no problem at all. Also if i remux stuttering version 3840x2160 to 3840x1606 like most of the blu-ray rip has, there is also no stuttering.
My older box with S912 play fine all of those rip without stuttering. Problem is only with N2.

Remuxes are not affected, only encodes with x265 version 3.1.*+. The CE team has acknowledged the issue and will look further into it. In the meantime, use seek to prevent stuttering on Amlogic-ng (S905X2, S922X etc) or use old Amlogic (S905,S912) for playback of encodes.

Hint: All releases which are marked x265 are encodes, and you can easily see it in mediainfo with

Writing library: x265 version [OS etc.]
Encoding settings: different parameters

I’ve successfully switched from meson-ir to amremote.
Amazing how much better this works.
I had to switch to RC6 which works fine with: “fdtput -t u /flash/dtb.img /meson-remote/ protocol 5”.
But the dtb.img will be overwritten with every update and I have to reactivate it.

Does anyone have a hint how I can set this permanently ?

I did a clean install last week and have faced an odd issue lately which happens 2/5 times. The issue is related to network and CE as I can’t access the internet or CE settings. However, I can connect to my N2 with ssh, SMB etc, yet I can’t fetch data from the internet. Besides, I can’t enter CoreELEC settings at all. After a reboot, the network connection is likely fine and I can access CoreELEC settings…

The connection is wired and N2’s IP is bind to the MAC in DHCP of my router. I’ve turned on/off the firewall in CE settings, changed skin back and forth between Estuary and MOD V2, changed network cable etc., but the issue still occurs. Any tips are appreciated! Will do some more testing tomorrow and try out earlier nighlies to see if they are fine. The last resort is to setup everything again manually which I did last week.

Update 1:
It seems N2 has access to the internet as I can ping and even download files to N2 with ssh, yet Kodi can’t seem to access the internet and CE settings are unavailable. As this is a unique case, it’s not worth looking into, so I’ll do a complete re-install.

Update 2:
After a hard reset and re-setup of everything, the issue seems to be gone. If it happens again or with anyone else, we should probably look into it further. For the time being, leave it as it is.

is there a simple way to update the iptv simple addon? i never cross-compiled anything myself. is this just: download the source, crosscompile, ftp the built file to the plugins dir, install it from kodi? anyone experience with that?

the iptv addon is very outdated. i use it every day and i encounter some bugs which are fixed in the latest releases.

I never compiled just the addon itself. You can build CE, and then building the addon takes 3 seconds.
It’s possible to try and build the addon only, this will build all required package, which will take a while, but may work too.

thanks, i will try that the next weekend. i hope the documentation is beginner-friendly :smiley:

is anyone else having this problem too?

pvr.iptvsimple/archive were bumped to latest 3.8.7 yesterday, so they’re in the latest nightly.

1 Like

does anyone know if there is a problem with epg and iptv simple? it takes quiet long when i start coreelec until this gets resolved. it looks like there is something “blocking” but i can watch youtube etc. while this update dialog on the top right screen is visible.
kodi starts when i have a network connection.

i hoped the update of the plugin would solve that, but it did not

Fired up my N2 the other day and after some setup/teething issues it’s now up and running really well. Well done to the crew for the efforts in supporting this new device. HDR looks excellent through the N2. The extra power over my old s905x is evident. Happy to test HDR10+ in the future when it is supported as my TV supports it all. Well done.

Hi,
Latest 9.2.1 build finally solve the issue with AAC and FLAC audio formats, so it’s not needed to use a workaround (2.0 channels + AC3 transcoding enabled) anymore.
Would like to say BIG thanks to all who are developing CoreELEC. You are doing amazing work.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice