Odroid N2+ very slow LAN download in 1Gb network


I have Odroid N2+ 4GB board with ​CoreELEC 20.0-Nexus installed od micro SD card. I keep my media files on a Synology NAS. Everything is connected via a 1Gbit switch and cat.6 cables.

Yesterday I tried for the first time to play a 60Mbit/s high bitrate video (from a GOPRO camera) and noticed the video was very stuttered, sometimes stopped completely. I uploaded the video to an SD card on the Odroid and it played smoothly without any stuttering. So I tested the network connection using iperf3 and found that sending from the Odroid N2+ is at maximum speed, around 950Mbit/s, but receiving is at 100Mbit/s or slower. The Odroid connects to the network at 1Gbps. I repeated the tests several times, each time restarting the Odroid. The download results were always at 60Mbit/s…200Mbit/s, upload 950. I changed the cables and switch, but this did not help. I even tested on another network at my friend’s place and the download was also very low. The playback of lower bitrate content is without problems.

As a trial I installed Libreelec and here everything works as expected, i.e. upload and download is at 950Mbit/s.

Please, can anyone help?


Just for speed tests try with 20.0-Nexus_alpha3 release and test your speeds. If normal upgrade again to 20.0-Nexus and try again please.

Ok. I’ll let you know in couple of minutes. I forgot to add that the same problem was on a version of the
CoreELEC 19.


Forgive my naive question - where to download the Alpha3 release from? Or, do you mean night builds?
My current image is: CoreELEC-Amlogic-ng.arm-20.0-Nexus-Odroid_N2.img.gz.


I will get back to you later. My SD card got damaged, I can buy some new ones for tests.

I have Odroid N2+ 2GB board with ​CoreELEC 20.0-Nexus.

The same issue is that the network speed is very slow. Only low-bitrate content plays smoothly. If playback is paused and resumed it will stutter, even with low bitrate content.

CoreELEC-Amlogic-ng.arm-19.3-Matrix work excellently without any problems (network speed is great and no stutter if I pause and resume.

20.0-Nexus_alpha3 seems to work too with good network speed.

Hi Portisch!

Thank you for you advice. With 20.0-Nexus_alpha3 network performance is ok, download and upload are over 900Mbit/s. So I installed then stable 20.0-Nexus from the scratch, on the new SD card. And unfortunately, download is very low again, about 80Mbit/s. Upload is ok.

Can you please investigate, where is a problem? Do you need additional data, logs, etc.?

Best regards!

Amlogic-ng-ethernet-dtb.zip (1.0 MB)

Please pick your needed DTB from the zip file and test again with latest 20.0-Nexus release!

Please confirm if the issue is solved with the DTB from this ZIP-file!

Only for Amlogic-ng!!

Thank you for your co-operation.

I’v just installed from scratch the latest 20.0-Nexus 3 release and replaced the dtb.img withe the one from the attached zip file. I did the iperf3 tests and it is ok. Download and upload are the same and are over 900Mbit/s. Are you planning any further actions?


You need to to the test on stable 20.0-Nexus release and not alpha 3. I mention this because your post is vague.

Hi Vpeter!

My test was done with stable (not Alpha3) image CoreELEC-Amlogic-ng.arm-20.0-Nexus-Odroid_N2.img.gz downloaded from https://coreelec.org/#download, and new dtb file from attached zip archive. And now my N2+ box has download and upload almost 1GB/s.

So it looks like I did as you wanted?

Yes. Just wanted to be sure :slight_smile: Thanks for the test.

One more question. If there is another update, will my network probelm return? Or, will the new image include a revised dtb for the Odroid N2+?

Correct. You can confirm with tomorrow nightly build from here: CoreELEC nightly builds

Does this mean that the existing dtb, or kernel, contained errors (or was not optimally adapted to the hardware dependencies) from the very beginning? So far, I have only played low bitrate content and have not considered the problem of slow downloads. Have other users of this SBC not noticed this problem?

Hey @robertpos. Yes I am having the same issue as you right now. Here is the thread I started Network connection issues on Odroid N2+

I have been trying out the new dtb fix since last night and I’m not 100% sure if this solves it for me yet. I am still getting somewhat inconsistent speeds. But so far the slowest speed I have gotten is 78mbps (should be getting about 93mbps). But I have yet to have any very slow speeds as I was having as slow as 15mbps sometimes and I have yet to have the connection speed drop and stay there. For example when it dropped down to 78, I ran another test 30 seconds later and it was back up to 93 again where previously the slow speeds would remain slow until I toggled the connection on/off. So hopefully this is a good sign. I am going to keep testing for another day or so, because the other issue I had is that my network would slow down somewhat randomly. Where I would toggle my connection and the speeds would be fine for the rest of the night and the following morning, but then drop again later the next night. If I can go a whole two days without seeing the speeds drop I think I would consider my issue solved.

Hi hiddenumber!

My Odroid N2+ is connected to 1Gb/s network, by cat.6 wire. Movies are stored on Synology NAS, also connected to 1Gb/s network. It looks like this:
Odroid - cat.6_patchcord - 1Gb/s_switch - cat.6_patchcord - 1Gb/s_switch - cat.6_patchcord - NAS.

Yestarday I made a lot of tests using iperf3 (in both directions) and always got about 950Mb/s transfer. Then I started to play high bitrate movies (from GoPro HERO8 and Insta 360 GO2 with average bitrate 60Mb/s) and all was OK. I watched about 90 minutes of footage and there was no stutter.

On the previous version of dbt I was not able to watch any high bitrate video, because it stuttered in the first seconds. At that time, iperf3 download test results were around 60…200Mbps, but there were times when the result was at 0.5Mbps!!!

I did some tests today and still everything is ok, i.e. the up and down transfer are around 950Mbps.


I did some more tests today myself and I think everything is looking good on my end as well! Consistently higher speeds and still have not gotten any very slow speeds during any of my tests. Haven’t run into any buffering since installing the fix either. Thanks for the quick fix @Portisch!

@Portisch why did you remove the link to the thread I posted? I’d like to have it here since others may find it helpful.