OpenVFD Settings Problem (Solved)

On my X92 box (CoreELEC-S912.arm-8.99.2 with gxm_q201_3g_1gbit.dtb) I use it for a long time to show only clock and temperature every 30 minutes, and it works OK.

I wanted to turn ON some icons but those options are now all grayed out. Only option available is “Turn Display On/Off”. Choosing “Default Setting” turned all icons ON without the possibility to choose any to turn OFF. Had to overwrite “settings.xml” in addon_data with on old version from my older backup to turn all icons OFF.
This used to work on former versions and I don’t know when it stopped.

How can I get the options for choosing icons to be selectable?

You have to make sure that “Turn on display” is enabled, then you should have all the icons controls enabled. This will let you turn the icons you want on/off.
Sorry, but I couldn’t reproduce this issue.

At worst case, disable the addon, delete the settings.xml and enable the addon. Then configure it how you want.

No success.
Before deleting settings.xml:

After stopping service, deleting settings.xml and restarting service:

The only difference is 2 selected vs all selected with fresh settings.xml
No big deal, only curiosity, because I can turn icons on/off ba editing the settings file.

That’s not how it’s supposed to look. Maybe your addon is corrupted, try to uninstall and reinstall it, then restart Kodi.

I did that, uninstalled/installed several times paying attention to get most recent ( from CoreElec addon repository.
And I know how it’s supposed to look, because it looked like that on my box some versions ago.
Also on my box the brightness settings has no effect, it’ always max

Try using the default Kodi skin, maybe there’s a problem with that.

I am using default Kodi skin, Estuary (2.0.21) only with Charcoal color…

Odd. My box has the same version and I don’t have this problem :frowning:

Just to follow up:
Did “Software Reset” -> nothing changed -> so it’s not my settings.
Did “Hardware Reset” -> (same as fresh install?) -> nothing changed -> so it’s not my addons.
No way to get any Indicator selectable!

So, I suppose it’s either my hardware or your software…

I managed to reproduce it, and pushed a fix.
Should be fixed in next nightly.

Great :smile:
What is the fix?

TK redesigned the addon settings.xml format, and I guess they introduced bugs in their compatibility layer for older addons.
What I did was simply remove the functionality that disabled the indicator controls if the “Turn on display” option was disabled.

OK tnx, will try it out.

It was enough to update OpenVFD to v. to get everything working as it should. All Indicators can now be de/selected

1 Like

Well, my Indicators problem is back. On CE 9.0 the working version is messing up things so I can’t use it and with verssion I can’t select any Indicator.

Just to make things more clear, it messes up my 9.0 final 2019-02-16 and works well on
my 9.0 2019-02-15 version.

Could you check if after switching off indicators you have an issue?
If not, than please switch your indicators back one by one to find what caused an issue

Somehow I’m afraid to install to have problems again on my main instalation.
Will tray you sudgestion later with my spare/testing instalation.

Btw, I use and have selected only 2 indicators (as seen on my SS above) so it should be simple to test

Edit: and also have selected to display temperature every 30 min.

Installed v. and disabled all indicators and options. Small file ( smaller that 100Mb) copy/move worked. Copying a larger file (about 350Mb) froze the system…
Unistalled OpenVFD and tried copying same file (350Mb) with resulted in partial copy of only about 130MB although system showed finished copying complete file.
Did OpenVFD mess up the system so much or I have some issue with my hardware is not clear to me…

I’ll try later with my USB stick to exclude possible SD card influence.

Well, I am sad and happy :frowning: :slight_smile:

Happy that everything, CE 9.0 + OpenVFD, work fine and as expected. No problems at all with my Sandisk USB 3.0-32Gb stick.
Sad that my new Sandisk Ultra-32Gb SD card is not working, and is causing all problems.
I’m sorry that I made such a fuss because of that.
Moral: use only Sandisk Extreme SD cards, like all my rest SD cards, for peace of mind.

1 Like