OpenVPN in CE 9.2.0

Hi, has anyone had any luck with using the Zomboided VPN Manager to access ITV or BBC iplayer, please? I have tried several VPN providers and it always says connected, however the add-ons in question still give me the UK-only error. When I try the same on Android, using the VPN providers native apps, they work w/o issues :frowning: Is it a different connection type / Kodi restriction / CE problem?

The logs are here if it helps:

remove / disable vpn manager and try manually using the terminal:

openvpn --config /path/to/your/file.ovpn

This will show you if you are really connected and then try using players

no change. the VPN stays connected, which I can confirm with my local TV streaming addon (it stops working as expected). I think it has something to do with the DNS - I have attempted to change the severs manually to the ones provided by BulletVPN but then the ITV plugin just takes MINUTES to load, only to end with similar error as before.

Did you do what I said, doesn’t look like it from the logs

Its unlikely you will get around the blocking by the UK providers. They monitor IP addresses and if there is multiple traffic from the same address they assume its a VPN and block it.

There are vpns which offer unique IP addresses but they cost a lot more.


if you are not afraid !?

Sometimes here shows vpn for UK this is not a permanent option but good for testing

Personally, I always use VPS, choose a country and configure my own vpn OVH is cheap 2.50 - 3 euros for month

yes, I did, but since there was no change in behaviour I reverted to VPN manager when trying out the DNS servers change - simply because it is easier to connect than using the command line on a PC which is in a different room than my Kodi box. I can post the logs later but thought the only purpose of the exercise was to prove VPN stays connected, which it did (there was no message in the ssh window indicating otherwise).

I could understand that explanation if the same VPNs did not work for the same UK providers when connected outside of CoreElec / Kodi.

Its an absolute fact that the BBC and ITV monitor heavy traffic from people using the same IP addresses as used by basic setups such as the OpenVPN software used in CE . I also can guarantee that the OpenVPN addon functions as a real VPN service and tunnels all your traffic to the remote gateway. I have been using mine for over a year at this stage with no issues - other than not been able to access BBC most of the time.

This is well documented behaviour for Kodi/CE and VPN services.

Using the VPN providers own software may make it appear differently to OpenVPN from Zomboided.


My experience is quite similar to Shoog’s. I have a Surfshark subscription and with Openvpn I couldn’t bypass geographical locks. This was 2 weeks ago. This weekend I tried it and it worked. But I’m no using it for BBC. After googling a bit I saw that, as Shoog says, it’s documented and there are posts from Zomboided himself addressing the issue.

thanks, guys. in other words, I should not expect to ever make this (ITV/BBC) work in CE (?)

If you use a service which offers unique end point IP addresses masquerading as the UK then they will certainly allow you to access the BBC/ITV. I do not know of who offers this service, but I know that some companies certainly do.


I wouldn’t say that. It’s maybe a case of hit and miss with vpn providers.

1 Like

how do I use the dedicated IP address in the VPN addon?

I do not know, but if the VPN service which offers dedicated IP addresses is supported by the addon it should just work. If not then you would have to setup something like a router based VPN.

This article discusses the service providers for unique IP VPN services:


I know how to select a VPN provider with a dedicated IP address, I just don’t understand how that could be utilised by the Zomboided’s (or any other) addon, or by the openVPN command line instruction, in Kodi running on CE. There is no such option so I am a bit sceptical about the ‘it should just work’ part. (For the record - I have tried, with VPNArea, and it does not).