Openvpn Setup

I don’t see any threads that are solving my issue, so hope I’m not duplicating. I’m running CoreElec 9.2.3 on an Odroid N2, and Kodi. I’ve been trying to set up a vpn client. First question:

  • I’m not even sure I need it. Whenever you look at installing Netflix, Prime or any service, it suggests using a vpn. Is this only if you are planning on bypassing the Geo-lock limitations, or doing something illegal? As I simply want to access services I’m subscribed to, is it really an issue. I don’t use a vpn when I run Netflix on my laptop, for instance.

  • Assuming I should install a vpn, I’ve spent about 3 days on it, and am still getting no love. I have an existing ExpressVPN account. I’ve installed the zomboided repository and addon. Since there’s no “desktop” per se on CE, I either configure via Kodi or ssh. In kodi, I enter the details, and the ovpn file location, but I keep getting an authentication error. The ExpressVPN username and passwords are both about 24 characters long, so I enter them, but since I can’t copy and paste, it’s possible I’m miss typing. Is there a way in the OpenVPN manager addon to simply import username and password?

  • I ssh into the box and can issue openvpn command and point to the ovpn file. From there, I can cut and paste both username/password, and it appears to be working ( ifconfig is showing a tunnel address, so I assume that means the vpn is working ). If I can’t get the addon to work, can I figure out how to get the box to always connect the vpn on reboot, and simply ignore the addon?

Thanks.

OK. I think I’ve got it. Assuming that the VPN doesn’t slow things down tremendously or put a burden on resources, I’ll simply run openvpn from startup, and ignore the addon. I created the autostart.sh executable file in /storage/.config with the command:

openvpn --config ~/VPN/my_expressvpn_xxxx_udp.ovpn --auth-user-pass ~/VPN/password.txt

I imported the ovpn file from Expressvpn, and created the password.txt file with my EVPN username/password. Did a reboot, and the tunnel came up automatically.

Now, the only question is- what if the tunnel drops for some reason? I won’t see it in Kodi, I assume. Also, in order to drop the tunnel, I have to ssh into it again. Also, my script only points to one ovpn location. Not ideal, but should work. Has anyone else used this solution to run openvpn on CE?

What do you mean, no “desktop” per se? After installing the zomboided repository, one installs the VPN Manager for OpenVPN add-on.

From there it’s as simple as clicking on the icon, going to Settings / VPN Configuration. Choose the VPN provider (Express VPN in your case), enter username and password and hit OK. Under Monitor, one can set “reconnect if connection is lost”.

If one decides to have a long or complex username and password, be aware it will have to be entered manually. Copy and paste aren’t an option in the native Kodi interface.

The VPN manager has an option to show the password entered so it can be verified (Settings / VPN Configuration / Show Password)

All this information is also available at the Zomboided OpernVPN Manager Wiki, which should be the primary source of support for this Kodi add-on.

UPDATE:

There is a workaround for copy/paste.

One can use and Android app such as Yatse or Kore.

@Vascobraga: If you use Yatse or another remote app you can copy paste the username and password with your phone.

When I say “there’s no desktop per se”, I mean that I can’t simply go to the desktop and copy and paste. Now, I’ve done all the things that you say. I’ve installed the repo, installed the manager addon, gone into settings, chosen my provider and manually entered and checked, at least 3 times, and it continues to say there’s an authentication error. Also, I don’t have a choice about the username/password. It is what Expressvpn assigns to me, and I don’t believe that I can change it ( I can change my password to their website, but not for the connection ). I will doublecheck this with Expressvpn. In any case, it works fine if I simply do it by ssh. I just don’t want to have to go upstairs, get my laptop, log in remotely, and change it, every time I need to change it. I’ve certainly looked at the wiki. It just doesn’t seem to work.

I’ve setup twice the openvpn manager today. If you use Yatse or another remote app you can copy paste the username and password with your phone.

1 Like

Thanks all. In the long 24 character password, there was an l that looked like a 1 . Thought I’d tried both combinations, but eventually I got it right. I’ll look at the Yatse app. Not familiar with it.

1 Like

Thank you. I use Kore and hadn’t thought of that.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice