Play to Kodi browser addon

Hello,
On previous devices and builds I have used ‘Play to Kodi’ browser addon to cast video to Libreelec, Coreelec and OSMC from browsers Brave & Librewolf on my Linux laptop.
On my Beelink GS king running Coreelec 19.2 this is not working.
Other similar addons are not working either. eg Send to Kodi
Do these browser addons work with 19.2/Matrix?
Librewolf says cannot connect.
Brave brings a pop up on Kodi saying 'Playback Failed: One or more items failed to play.
Thanks.

Last time I checked this addon worked.

Please enable Kodi debug log and try to play something. Maybe something will be visible in log.

Works fine for me with matrix from all browsers.

Hello,
I sftp-ed into Coreelec and found a crash log. I am not sure if it is the correct thing.
I could not see anything relevent -but I am not sure what to look for anyway.
The only recurring error I could see is:
Your hardware does not support AE_FMT_FLOAT, trying other formats
but that seems to be about sound.
Any advice on where to look and what to look for?
nb the crash log was too long for Hastebin

Have you tried other browsers?

Librewolf and Brave. Both which have worked previously, so I doubt another Browser would be any different.
I now also tired Coreelec 9.2.7 (on sdcard) and 19.2 (installed to emmc).
Same behaviour. Casting awakens Coreelec but then nothing.
It would appear to be a network or Kubuntu issue then - ?
I have tried with the Firewall disabled.
Still no connection.
Could there be a router setting that needs changing? Not that I recall changing anything in it.

Enable Kodi debug logging and check if there is any clue.

I sftp-ed into Coreelec and found a crash log - but are you referring to some other way to debug?
Thanks.

Ok, wow! Coreelec has an inbuilt pastebin! :slightly_smiling_face:

http://ix.io/3weX

Enable DEBUG log in Kodi, try to connect from your browser, then upload log file.

Crash probably doesn’t have anything with your problem.
Also enable “wait for network” because I think there are some errors with network.

Ok, I finally found ‘Logging’ in the settings and enabled debug.
Connect from browser? I entered the IP address: https://192.168.0.2/8080 but get
'This site can’t be reached

192.168.0.2 refused to connect.’

“wait for network” is enabled and set to 10 sec.

It should be http://192.168.0.2:8080

1 Like

I tried that too and it does not work either. :confused:

Oh! Now it does! :astonished:

1 Like

Done.

re:

Sorry, I cannot see how do this.

Doesn’t matter anymore - issue resolved.

No. I still cannot cast with ‘Play to Kodi’

got me to the web interface
but that is all.

I use to use ‘Play to Kodi’ with LBRY.tv for most of my video viewing. This has now been replaced with odysse.com.
I decided to check with youtube. This works!
So, it would seem the odysee.com is the issue.
I will lodge an issue there and close this thread.
Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice