PLEX media server

Hi, How can I install Linux Plex Media Server on CoreELEC? Thank you for any advise.

I see, you already posted your question in the LE forums:

Though you won’t get an answer to questions regarding CE in the LE forums, I assume, the process installing it is nearly identical to the one in LE:
Just download the latest zip file and install it as an addon:

I tried, but when I click on that link, nothing downloads…

You can set it up in Docker

Only if I knew what Docker is :). Sorry. Thanks for help

With docker it is possible to distribute and run applications in a container format, which contains all dependencies for the specific application.
Just do a Google search for docker and you’ll find a lot of HowTos and hints on how to use it.

To install docker in CoreELEC, you can find a docker repository in the CoreELEC addons repository.

Got it. Thanks for help guys. Plex server up and running. The Plex add-on is enabled, but when I go to “” from my browser the Plex website doesn’t load. Do I have to do anything else?
The IP address is 100% correct. Thanks

My knowledge of docker is not very extensive, but it’s a “container”, so the port Plex is listening to has to be forwarded in your OS (in this case CE), so that incoming traffic to that port will be forwarded to the Plex server.

I’m running CoreELEC in KIII Pro and I’m trying to access the PMS from an iMac on the same network. Do I need to forward some port on in my router?

No, you need to read up on how to forward the port in linux to a docker container.

OK, looked into it and tried different commands through SSH but to be honest, I’m not 100% sure what I’m doing and I don’t want to mess up my CoreELEC. If there is anyone one who can tell me exactly step by step what to do to forward that port I’d really appreciate it. I really tried to figure it myself but no luck. Thanks guys

Not sure if this will help as I’m not running plex but the principle should be the same. When i create a docker container I choose the ports to forward like this.

docker create --name=tvheadend –net=bridge -v /storage/docker/tvheadend:/config -v /storage/recordings:/recordings -v /storage/tvheadend/files:/files -v /storage/picons/tvh:/icons -e PGID=0 -e PUID=0 -e TZ=Europe/Helsinki -p 9981:9981 -p 9982:9982 --device=/dev/dvb lsioarmhf/tvheadend-aarch64:release-4.2

Which will forward ports 9981 and 9982 on my CE to my docker container.

1 Like

Please see attached my docker info. I think the PMS should show up here, no?

So you have 1 image downloaded but 0 running. What’s the output of docker images and docker ps?
EDIT: docker ps is wrong. The command I was looking for is docker container ls

That image is actually portainer. Which I installed, tested and removed. Just to see if it’s working. And it worked fine. I think It’s weird that when install the PMS add-on in Lodi, it happens very quickly… few seconds. But it should take a while I think. I managed to download PMS manually with this command: docker pull linuxserver/plex
And then run it too. But still couldn’t access it through the web.
See attached screenshots

So far, the only way I managed to run PMS is when I installed NON docker version zip file, as a classic kodi addon. It was working fine, but it’s too old and when I tried to update it, I had no success. I used this method:

I got this error after 2nd command: ar: invalid ar magic

Not a big expert in docker but I believe you’re missing the whole create container part. So I pull image, create a container (similar to what I’ve pasted a few days ago) then I start the created container.

Here’s some idea how to create the container for plex .


yeah, that’s the web, where I found that command to pull the image in top right corner. docker pull lsioarmhf/plex

Do you think that I have to run all these command to create container from the image file?

docker create
-e PUID= -e PGID=
-v </path/to/library>:/config
-v <path/to/tvseries>:/data/tvshows
-v </path/to/movies>:/data/movies
-v </path for transcoding>:/transcode

I was just thinking, is it possible that the Plex server doesn’t install properly because I’m using CoreELEC and not LibreELEC? See attached screenshot from CoreELEC when installing PMS from linuxserver repo.

Back to docker. I created this command:
docker create --name=plex --net=host -ePUID=1001 e PGID=1001 -v /storage/dockerplex:/config -v /storage/tvshows:/data/tvshows -v /storage/videos:/data/movies -v /storage/recordings:/transcode lsioarmhf/plex

And the response was this: 143d21522e6a986dcc69fda7366b9e19446e9a50400f7305ee39b47645f18fa2

What’s next?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice