PLEX media server

You’re forgetting to forward the port for the plex server. Unless --net=host is supposed to do that for you automatically. Why don’t you just forward the ports Plex Server needs?

You also need to run the container, you’ve only created it. It’s not running yet.

You have to do this next:

docker start plex

Here is a screenshot from my last ssh conversation :slight_smile:

it looks like the container is running. See attached what happens when I do “docker start plex”

Why would people use non-free proprietary software on CoreELEC? I dont understand it

Because they can

I tried to remove everything, pms and docker addons and also linuxserver repo. Rebooted the KIII and installed linuxserver repo and pms addon and then I run these two commands:
systemctl status docker.linuxserver.plex.service
and
journalctl -u docker.linuxserver.plex.service"
See attached screenshots. Looks like there is some problem with the container. What is also suspicious is that when I reinstall pms addon, it happens quickly… within 10 seconds. I know the pms file is big and it should take much longer I think. Also see attached screen just before I installed the pms addon. The middle line says: os.libreelec.tv - not available. Could this be the issue?

18

Martynet,
I have a set up where I can run Coreelec so I thought I’d give it a try. I get exactly the same results as you and I share your opinion as to the cause.

I say this because I’ve been running a docker version of plex successfully for months on libreelec 8.2.4.1 from wrxtasy. To set that up, all I did was enable docker, enable Linuxserver.io’s Docker addons (from the libreelec addon repository the same way as its done for Coreelec) and install plex from the list of available addons. To the best of my memory, when that was complete the plex web page was available. I certainly didn’t do any port forwarding and I had nothing to do with any ssh commands to get up and running.

Hope this helps in some way.

You should go with sonofdibnahs suggestion and install everything via GUI if it works.

Last time I tried it on CE, it didn’t work at all but that was many releases ago. Hence I usually only install docker via GUI and do the rest of the container operations manually.

If the GUI method doesn’t work for you I can suggest some additional actions.

Shit :slight_smile:
I didn’t want to go back to LibreElec. Will wait a bit and see. Maybe the Linuxserver guys could do something about it.

So, thanks to help in LibreELEC forum I changed LIBREELEC_ARCH to COREELEC_ARCH in file:
/storage/.kodi/addons/docker.linuxserver.plex/bin/docker.linuxserver.plex

And now I can Plex server is running and I can login into the web interface. But now when I want to add media folders from external hdds, I can’t see them. External hdds should be under var/media/ but now, there is no media folder. File structure is different. So there must be still another problem. See attached 49

Ok I sorted it out and all is working now! Thanks everyone for all the help!

Seem hard to use docker? Plex Media Server 1.13.8.5395 (latest) addon zip here. https://github.com/dnzmedia/plexmediaserver-elec/releases

2 Likes

That’s what I was looking for for ages. And how do you update the addon? Will give it a go anyway.

It’s working great so far. Thanks again!

Read through the github readme. Of course DISABLE the service first before update.

So, disable the addon first and then just install more recent zip file over it?

Yes. Disable first.

Hey guys, how are you?

I’ve been trying to install this addon using the zip file from this link, but actually nothing happens…It doesn’t download or install anything.

And yes, before you ask, I know how to install an addon. I’ve been using KODI for a while.

Can anyone confirm this issue?

By the way, I’m running the latest CoreElec version on Odroid C2.

Thanks!

UPDATE: Nevermind, guys. Just did a restart and now it’s working perfectly fine!

If you add my repository inside it has the plex media server addon updated for both x86_64 and arm

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice