Pptpd problem

Is there any possibility to add files (symlinks) to /etc without rebuilding the all squashfs system file?

I am trying to configure the pptpd server and I need the /etc/ppp directory to include the chap secret file in it. There is no way to configure this secret file to /opt/etc/ppp directory - hard compiled in pppd binary file

It would be great if there was a way to be able to enter own symlinks in /etc into a some configuration file.

Have you tried using entware for pppd?

Yes, I’m just using pptpd for entware.

For authorization to work, I need to have chap-secret file in /etc/ppp location.

I’m looking at the package

First: I must change /opt/etc/init.d/S20poptop

ARGS="-e /opt/sbin/pppd -c /opt/etc/pptpd.conf"

In default pptpd trying search pppd binary in /usr/sbin/pppd and no start pptpd process (service start problem)

Now when i strace i seen then pppd trying open /etc/ppp/chap-secrets file.
There is no config options to change this secrets file location - so i need add symlinks from /opt/etc/ppp to /etc/ppp.

https://www.systutorials.com/docs/linux/man/8-pppd/

Pppd stores secrets for use in authentication in secrets files (/etc/ppp/pap-secrets for PAP, /etc/ppp/chap-secrets for CHAP, MS-CHAP, MS-CHAPv2, and EAP MD5-Challenge, and /etc/ppp/srp-secrets for EAP SRP-SHA1). All secrets files have the same format. The secrets files can contain secrets for pppd to use in authenticating itself to other systems, as well as secrets for pppd to use when authenticating other systems to itself.

I think this is wrong. Strings here shows that this file is expected to be in /opt:

LibreELEC:~ # strings /opt/sbin/pppd | grep chap-secrets
/opt/etc/ppp/chap-secrets

And this is whole point of entware: nothing resides outside of /opt.

Yes I was thinking exactly the same as @vpeter

Thanks I solve problem.
The reason for not working my pptdp was setting in the configuration (using MPPE)
There is no kernel module in coreelec?

You would need to elaborate on which module is missing that you need.

In openwrt i use:

Package: kmod-mppe
Priority: optional
Section: net
Description: Microsoft PPP Encryption/Compression support

entware does not find this packages so i cant use
require-mppe-128
security