Problem turning an old TV box into a samba server

Hi all,
I had an old s905x box lying around and I wanted to turn it into a samba server on my home LAN to replace an obsolete D-Link NAS that is stuck to smb v.1. I installed CE 9.2.8 (since it’s probably the most recent version that is compatible) on it, then enabled Samba on the CE settings page. I made sure samba.conf.sample was renamed to samba.conf in the .config folder. I left the config file as default for testing purposes.

Now the problem.
From a Windows 10 machine I can browse the shares if I type \\coreelec in the address bar. I have to do that since I cannot find it in Network Neighborhood.
On a Ubuntu 22.04.2 machine the procedure that works is slightly different. In Nautilus, I have to type smb:// to access the share, only after having chosen anonymous connection.
Since I would like to mount the shares in fstab as a guest user, I tried mounting one on the command line but I am always asked for a password. None of the following worked to give me anonymous (public) access:

sudo mount -t cifs -o rw,guest // tmp
sudo mount -t cifs -o rw,guest,vers=3.0 // tmp
sudo mount -t cifs -o rw,root // tmp

I know that I am doing something wrong or misunderstanding samba but I need someone more savvy to nudge me in the right direction.

Ubuntu doesn’t provide command line access to shares using Windows UNC naming or Kodi enhanced naming like smb:// so you will need to mount the drive typically that is done using /etc/fstab. I am sure that web searching you will find out more.

Thank you for taking the time but as I wrote

the part in bold does work in Ubuntu Nautilus, it’s just that I have to choose anonymous to be able to browse the contents of Downloads. What I would like is to get rid of the password prompt since I want access to a public share whether it be in Nautilus or the command line.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.