Problem with Plex add-on - database migrations?

Hi everybody, I have installed the Plex add-on on Kodi but it doesn’t work for me. When I try to access from the browser to my server (http://“ip”:32400/manage) it doesn’t load, and I get the following message:

I have read in some forum that it is a matter of leaving some time and finish the migration. This has not been my case. I have also tried uninstalling and updating it several times, but it has been like this for 2 days.

I don’t know if it has happened to anyone, I would appreciate any help because I am very new to this. Thank you.

Plex Kodi official add-on is broken, at least for Nexus and in the last time. You should use PKC from croneter, Composite add-on from Kodi repo. Or just go with samba or NFS servers.

1 Like

Or you could install Plexmod from here

It works really well for me on Ng with both Kodi 19.5 and 20.1 versions.

1 Like

A friend of mine just told me that, it seems that PKC works really good for him. Gonna try it and lets see it works ok. Thank you!

1 Like

I’m going to try PKV because it has been recommended to me by two people by now, but if it fails, I have your link to the repository to install this version of plex. Thank you very much to both of you for your quick responses!

:grin: You also can go to Jellyfin, open source all the way.

I think I’ll try Jellyfin because I can’t get my head around Plex Kodi Connect XD I couldn’t create a server from my machine (an odroid N2+) and I had to connect to the one I had created on my computer… Also, my playlists are all out of date when I installed the add-on and I’m not getting the Kodi interface to work. I’ll try to keep looking at it tomorrow but I can’t get my head around it. Thanks!

1 Like

If you go down the Plex route, the server runs well on N2 using docker. A quote from a post I did ages ago to someone else…

Install docker add-ons repository from the CoreELEC (Nightly?) Add-ons repo. The Plex server for docker is in there. I’ve put (Nightly?) because that’s what I’m on. It will show differently if you’re on stable.

You might need a pointer as to how to point the server to your media libraries . I’ll post again once I’ve found what I put to someone who was struggling.

You set up directories in the Plex add-ons settings. These are for Music and TV shows only but music will work from them (or in my case it)

Quote from earlier post that’s the best I can do to explain.

In the Services add-on “Plex ” I have set var/media/Toshiba Ext/Media for both the sources (movies and TV shows). Toshiba Ext is my storage device Media is a directory (which contains subdirectories called Movies, Music and TV shows).

I then went to the Plex webpage ( in my case), added a library for music and linked it to the Music subdirectory when it asked for the source.

This is what I have tried to do but I am not able to get it to work. I have docker, and I even have the library paths to my hard drives as you explain. But none of this seems to work. I’m going to uninstall and reinstall everything this weekend and see what happens, thanks a lot for the info!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.