Problems with dns resolving in Elementum addon

Hi, I have a problem with elementum addon (tested on Coreelec 9.2.5 and then downgraded to 9.0 with the same results)

I can’t use elementum anymore. For a while when I make a search, it scraps the torrents, I choose one of the list, it shows “resolving magnet” and then, after a while of triying to resolve, the message “Playback failed. One or more items failed to play”.

I have posted this issue on elementum github (github .com/elgatito/plugin.video.elementum/issues/661) , and even libtorrent github (the torrent library used on the addon github .com/arvidn/libtorrent/issues/5798). Both developers can’t find the cause on the logs I’ve posted. I have enabled the setting “Wait for the network to start” but nothing changed.
First, it was the suggestion that it was a network issue, but I have tested this on a PC with the same Kodi and elementum versions on the same network and it works normally. I’ve tried a clean install of Coreelec and then installing only elementum, nothing changed.
Elementum worked on previous versions of coreelec (I haven’t changed internet provider or router in years), so I am thinking maybe is an OS problem.

Here’s some logs about the problem and settings on my router
https://paste.kodi.tv/etaxipabos
and https://paste.kodi.tv/regimofoco

I would appreciate any help about. Thanks

Illegal addon, no help with that.

I´m thinking nobody will do something.
There is no legal use case

About | FAQ | Terms of Service | Privacy Policy | Legal Notice