Ps3 controller BT pairing issues

Hi,

I am having issues trying to connect my PS3 controller via Bluetooth, here is a lot of the things I’ve already tried:

*Connecting it with a USB cable it responds quite well, when I disconnect the cable I immediately press the home button but it never connects.

*Already tried connecting it via USB and selecting trust and connect, it didn’t work and the system crashed and rebooted, also tried deleting it from the BT list and adding it again, it didn’t work.

*Joystick support is enabled and all the buttons have already been configured when connected with the USB cable.

*Ps3 DualShock controller add-on has already been installed and updated.

*Bluetooth is enabled and it shows the ps3 controller available for pairing when I press the home button, it even shows the controller as connected but none of the buttons work and the 4 lights on top of the controller blink until they just turn off without pairing.

*I even installed the nightly version because I saw an old post that said that was the fix…it didn’t work.

I know is not the BT signal of the controller because it pairs with windows and the ps3 with no issues and I know it’s not the Bluetooth dongle because other devices like headsets, phones are pairing to coreelec without issues.

It’s so weird because it paired without any issues a few days ago and it suddenly stopped working.

I am all out of ideas, any suggestions?

Thanks!

Is it an official sony PS3 controller, or a clone?

What device are you trying this on?

If bluetooth is via an USB dongle, which one are you using?

I just connected a PS3 controller a couple days ago when I was trying to sort out an issue with one of the emulator cores. I connected via USB cable, pressed the PS button on the controller, then disconnected the cable and it connected when I pressed the PS button after that.

It is an official PS3 controller.

The device is a Mecool M8S PRO W 2.4G

The Bluetooth is a Harmony CSR 4.0 dongle.

I did connect it with the USB cable and pressed the PS3 button and it worked for about 3 or 4 days, but it suddenly stopped working a few days ago and when I try to do the same thing I did to get it working before, nothing happens, the lights just keep flashing until they turn off and the controller never connects.

I know I have had issues before when I have attached my PS3 controller on an other device to charge then tried to connect to the device running CoreELEC again. But usually just going through the Pairing with the cable again fixes that.

I guess you could try resetting the controller as well, the reset button is normally found on the bottom of the controller on the side that has the leds. It takes a paper clip or tooth pick to press. Press this then try again.

I already did that too and it didnt work.

i dont know what else i can do.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice