PS3 Dualshock 3 over bluetooth (SOLVED)


I am trying to connect my ps3 controllers over bluetooth, so I can use them in the emuelec app, I have a S905X3 box updated to the last nightly, bluetooth seems to be working, I can see some discovered devices, and when I connect the controllers over usb they work, but it is not possible to pair them.

Please, can someone help me? Where can I see the bluetooth logs for further information? I checked in the logfolder but It seems that is not there where I need to look.

Thank you in advance.

What’s the big secret in disclosing your hardware’s brand identity ?
The SOC has nothing to do with WiFi / Bluetooth issues.
Maybe you have a branded X96 xxxx ?

It’s a X96 air 4Gb\64Gb, then, can I post more info here that could be useful?

Plug the controller in through USB.
Go into the CoreELEC settings and hover on bluetooth. You should see the controller listed there (but not connected). Select it and choose pair. Unplug the controller immediately and hit the home button to pair it.

Hi Ibernstone,

Thank you for your help, but I tried this several times:

  • When you put the controller using the usb it never appears in the bluetooth list, but you can use it.
  • If you disconnect it then it appears in the list, and you can click on pair, but it gives different bluetooth errors.
  • I managed to have it connected in the list, and sometimes when you press the ps button without the usb connected the controller number led blinks for just one second, and that’s all (The controllers are working and fully charged).

All that needs to be done to pair a PS3 Dualshock 3 controller is plug it in to the device with a USB cable, press the PS button, disconnect the USB cable. It’s now paired. No need to do anything in the Settings addon or anything else.

This is not working for me.

Hi, I found that there are some firmware updates for this box, does the firmware do anything when Coreelec is running? Do you recommend me to try the update? I want this to work, we still have here a lot of days of quarantine and this could kill a lot of time together, but I don’t want to brick it in such circumstances.

Thank you in advance.


I updated the firmware but it seems that is just an android update, and it is not affecting Coreelec. I’m out of ideas now, any help?

Do you use the original gamepad or clone?
I have the same issue with Gasia PS3 clones.

Mine are original PS3 controllers.

Ok guys, the last nightly solved the issue, so it is closed now.

Thank you!

How did you fix this problem?