Pulse Eight CEC not working issue

I don’t know what it is, but before under raybuntu’s community build under libreelec and very recently under corelec everything was working fine.

When i boot up the box it would say pusle eight connected and i would be able to control my amplifier using just my ordinary box remote. When kodi would go to sleep it would turn my amplifier off and when it was activated again it would turn amplifier on.

It would also wake up the tv from standby if required. Lately it hasn’t been doing that, No message on boot up. volume up down shows an icon on screen turning kodi’s internal volume up and down. No tv connected or audio connected messages. Sometimes i can “force” it to recognise by type “cec-client” in the terminal. It however hangs half way through and i have terminate it but none the less i can start using my remote again.

How do i go about debugging this? has something changed since the last update?

After further reading in this forum, I can see some others are also having sporadic CEC issues. @crazyturk have you got similar issues?

Same here. Neither the TV nor the AVR remote do work anymore.

Both worked perfectly fine before.

Yes I have similar CEC problems.

Try the following

fw_setenv cecconfig cec3f

It would be nice if people would at least say what device they are using.
CEC is handled partly through u-boot variables. We only build u-boot for our 4 Premium Devices which are C2, LePotato, KVIM and KVIM2. For generic boxes there is not much we can do.

This error sounds like CEC is/was disabled in Android or similar. Try the command Adam posted.

I apologize for not adding it. It is a wetek play 2 box. I will try it later today and report back.

I use a MeCool M8s Pro+

I just tried the suggested command (and rebooted, of course), but still no luck.

As said: it worked perfectly before :neutral_face:

It is a wetek play 2 box

I tried the command again, it doesn’t work.

That seems to have resolved it for me. I will test in the coming days for now it connects to my amplifier after a few seconds of it starting saying:

Connected: TV- Reciever

scan of cec-client shows devices but no physical addresses. But since it is working for the time being i don’t care lol.

CEC works on the 20181217 night image.

1 Like