PVR stops working when not exiting to menu

Since the beggining of using CE on my KIII Pro and KI Pro I’ve had one issue with my TVHeadend (DVB-S2) and PVR, which makes Kodi stop playing PVR channels if you won’t exit to the menu before switching a channel.

If you’re watching live tv channels and you jump from channel to channel using either up/down buttons or the channel number it works fine at the beggining, but after a while Kodi stops playing any live channels. You can exit to the menu, start playing any movie or tv show (which will work fine), and then if you’ll try to get back to live tv - you still won’t be able to play any live tv channels. It will start to work fine after CE reboot.

The issue is easily reproducable and happens all the time.

Steps to reproduce:

  1. Start watching Live TV
  2. Start switching channels using +/- (up and down) buttons
  3. After changing X channels (don’t have the exact number), some (or most) channels will stop working

The TVHeadend still works in the background but Kodi simply refuses to create a player window, and sits in the menu the whole time.

As a workaround for this issue you have to exit the player window to the menu before choosing another channel, otherwise you will have the issue after a while.

Logs: #

My configuration:

Devices: KI Pro (S905D) + KIII Pro (S912)
TVHeadend (DVB-S2) + TVHeadend PVR Addon - stable from CE repo
All versions of CE are affected

A small bump? :slight_smile: Does anyone else noticed this issue? I’ve observed it on at least 3 devices so I assume that I’m not the only one.

I can see, that you have two different versions of TVheadend installed:

10:48:21.809 T:4088947792  NOTICE: ADDON: service.tvheadend42 v9.0.118 installed
10:48:21.809 T:4088947792  NOTICE: ADDON: service.tvheadend44 v9.0.120 installed

Mabe that is the problem.

But most importantly:
You have also some blacklisted addons installed on your device.
According to our strict no-piracy rules, support ends here.

Re-opened again for further support with a clean installation on a fresh SD card.

Here are the updated logs from the brand new barebone installation of latest CE with TvH 4.2 (no duplicated TvH instances - even deactivated).

Any help would be appreciated. I’m sure some other folks would benefit from resolving this issue.


I tried this on my Mecool KIII Pro and I’m still running on 8.99.2 as I didn’t have time to do a fresh install. Using also tvheadend as backend. I briefly tried it and I can’t seem to reproduce it, or it requires more than 25-30 channels changes which I’ve done so far.

Maybe the issue is that i don’t have auto channel switching on up/down buttons so I need to press ok after up/down?

I think it’s even more than 20 or 30 but happens everytime so it’s consistent. During the whole day you certainly make this amount of zaps so I need to restart my device almost dialy. I had this issue across all of the versions of CE.

Maybe it’s related to the fact that you need to press OK to Zap. I’ve disabled that.

I’ve changed zapping behavior and will keep it on for the evening to see if it triggers. I just tried zapping alot for 4-5 minutes but I could not get it to trigger.The normal behavior seem to be that I get a still screen and then audio and video starts playing a while after that. On occasion I also get black screen or what seems to be estuary background but the player window still pops up.

In general the zapping is so slow for me that for the life of me I don’t understand why anybody would have this behavior on by default. It might have something to do with the fact that I’m having a CI CAM and part of channels I’m zapping to are encrypted and needs decryption.

I’m have DVB-C and I’m not using the mecool built-in dvb adapter.

Not using the built-in dvb might be a hint here. I’m using KIII Pro + DVB-S2 + CI CAM + built-in DVB adapters. Zapping is nice for me, it’s not instant but it’s not slow either (2-4s).

When you get the black screen from the estuary, can you exit the channel and try to enter it again? Does it load the player?

Maybe there’s an issue with freeing up the dvb interface after quick zaps? Is there any way to enable debug for the DVB interface?

I take it back, It’s blazing fast for me then as I would guesstimate it takes about 1,5-2s to zap.

I tried all sorts of stuff yesterday evening, zap fast and then re-zap while it’s still working on the previous channel etc. Also exit the channel and enter it again while it’s on the black screen or estuary background but I could not get it to fail at any point.

Not freeing up the dvb interface or something similar sounds plausible to me although usually you should get a notification about no free adapters. But it definitely sounds like something can’t keep up with the zapping but there’s probably an additional factor that impacts your situation as I’m fairly certain after yesterday evening, that it does not happen on my system no matter how I zap.

I do understand your frustration as I would be annoyed if I had to reboot. Unfortunately my knowledge of the logging subsystems is very limited. Have you ever tried to restart just kodi or only tvheadend over ssh, to see if either fixes the situation? If those does not fix it, I guess it would sound like a driver issue to me.

Thanks for the suggestions @Rascal :slight_smile: I’ll try 2 things today - after the issue will occure, I’ll try to restart Kodi alone without restart the whole box. I’ll also try the DVB drivers from CrazyCat. I’ll report back if there will be a progress.

Thank you for all suggestions!

Ok so I verified that it’s not a Kodi issue. After the issue happens I tried to restart Kodi alone (without restarting whole device) and also use some external (non-Kodi) related players to play the content and they also fail.

So it’s either a faulty driver or a bug in TvH. Question is - how can I get the logs from the DVB-S2 drivers? I want to investigate both TvH and driver logs.