Pyload on boot

Hello everyone, I try to launch pyload on boot but it does not work.
I tried with but the program does not run.

Sorry i’m french and google translation is my friend.

Does it work manually?
Try to use full path for program, configuration files, …

I use “pyload” command to launch on SSH.
But I don’t want launch manually at each boot.
I use this package with web interface


/bin/python <Path to pyload directory>/

In the

this line “python /opt/share/pyload/” launch pyload in ssh. i create file in directory “/storage/.config/” and chmod +x
when i reboot, pyload does not work

Then also enable “wait for network” in CoreELEC settings.
You can also delay executing pyload with this in

  sleep 15
  python /opt/share/pyload/

you can also make /storage/.kodi/userdata/ and execute from there with or without delay…

i activate wait for network in Coreelec settings and add sleep 15 to but does not work in kodi folder does not work too

I did not think it was so hard to start a program on boot

other problem : “/opt/etc/init.d/S51 Pyload start” command return “starting pyLoad and Daemon PID 4416” but the “/opt/etc/init.d/S51pyload status” command return “false”. and my web interface does not work.

This works here

  sleep 15
  pyload --configdir=/opt/var/pyload

But seems my pyload starts on it own without any extra autostart. Did you configure it first time?

it’s ok : the command /opt/etc/init.d/S51pyload start don’t find pyload config, the path is not good.
so pyload doesn’t start.
i have changed this path and the command /opt/etc/init.d/S51pyload status display the number of daemon and pyload start automatically on boot.

Thanks for your help
Sorry for my bad english, i did not find a french forum for Coreelec

After you installed pyload you saw the command how to start it. And after initial configuration everything was started automatically after reboot.