Rar support


#1

Hi Folks,

hope i posted in the correct place, as not sure of Kodi or Linux issue…

I recently set up coreelec on few of my aml boxes, and i noticed today it does not seem to pick up movies inside rar files, i have to unpack them for Kodi to pickup when scanning for new content. if i navigate to the folder in files view it appears empty (in other setups i would see what was inside the rar file)

I don’t have this issue with SPMC on android, or on any older version i used historically (xbmc on orig xbox, windows htpc and atv1 running crystabuntu and older versions of osmc)

Do i need to do something to add support for this in Linux, or is it limitation with current version of Kodi on Linux?

any advise would be most appreciated…

Thanks!!


#2

Try installing the VFS.RAR addon from the CoreELEC repository.


#3

Cool - that fixed it from a core kodi perspective, existing movies now play with no pop up advising it is missing asking if i want to remove from library, and scanning new media kodi picks it up

it is still an issue with artwork beef - i get error that it cant save to the rar (this used to be a problem with the addon when run in android with SPMC, i raised on the AB forum and rektor fixed it so AB saves artwork to the folder the rars (and zips as same issue the them)are stored instead of trying to save inside the rar / zip) guess i need to go back to the AB forum and ask again.

thanks for the help!!


#4

seems i spoke too soon, i found that even though kodi picks up the files inside a rar after installing the addon, playing back movies from library view is hit and miss. The new film i added played initially but after reboot (and several more reboots) it will not play from library view, i get the message no longer available, do i want to remove from library.

strangely however - if i navigate to the folder in files view, i can see the folder icon is replaced by the studio icon and it plays back just fine, and in library view if i go back and try to play it even remembers the resume point from when i tested in file view, but then i get the message no longer available etc…

what do i need to capture to try and understand whats going on? is it just the standard kodi.log in debug, or do i need to configure anything else in debug?

Thanks