Recordings have disappeared (SOLVED)

Hi all,

Odroid N2, 9.2.1 CE.

Today I have noticed there are no TV recordings showing in TvH. The recordings are on an NFS NAS share mounted to /storage/recordings. The recordings are in /storage/recordings but just do not show up in TvH.

I’ve rebooted a couple of times and done a Database update but still no recordings.

Any help appreciated.

TIA

Greg

Edit: Just did a new recording and it does show up in recordings. Seems it is only the older recordings that are missing.

Edit2: Permissions on new and old recordings are the same.

Have you looked at the DVR file retention period in the Digital Video recorder settings.?

Also check in the \CoreElec\Userdata\addon_data\service.tvheadend42\dvr\log directory there should be one file per recording if they have been deleted they wont appear in your list.

1 Like

The retention period is one month, so that is not an issue.

The \CoreElec\Userdata\addon_data\service.tvheadend42\dvr\log directory contains 29 files which seems to be correct.

TvH is showing the files as missing. See here.

However the “missing files” and the recording I did yesterday are in /storage/recordings. See here.

I have found the issue.

If I restart TvH after CE has booted the recordings appear. Reboot CE and they disappear until I again restart TvH.

Ideas??

TIA

Greg

BTW - CE is set to wait 30 secs for Network to be up before starting.

Are is Storage/Recordings a mapped drive? If so tvheadend may be starting before the share is live. When TVHeadend starts it scans the files in \CoreElec\Userdata\addon_data\service.tvheadend42\dvr\log each of those files point to the recording if it cant see the recording it marks it as missing. Delaying CoreElec start wont help you need to slow down the TVH start. My Files are stored on my flash locally so I have not seen this problem.

Its a bit of a fudge but you could add something like

(
sleep 60
<Command To Restart TVH>

) &

To your autostart.sh It would restart TVH after a Minute giving it time to start. There may be a way to start the TVH service after the network is up I am not certain.

1 Like

Found this in the TvH Server settings. Has fixed the issue.

Thanks for your help.

Okay in my setup there is a raspberry pi running libreelec as a TV Headend server and viewing is via a Minix U9 running coreelec. Recordings were often disappearing when the server rebooted (an infrequent event) The video files were there if the disk was moved to a linux box or NAS they just did not shgw in kodi.

The delay TV Headend startup setting pointed out by gregeeh fixed the problem. I set the delay to 30 seconds as I restart the server very infrequently.

Thanks for everyones help.

pvr.sql , live tv recorder (similar pvr iptv simple)

addon dev, @el_gonz87

tested and work on 9.2.4.2 (Stable)

more: https://forum.kodi.tv/showthread.php?tid=326896

About | FAQ | Terms of Service | Privacy Policy | Legal Notice