Red and Green Tint on PVR

Hello all,

I’ve had this issue since running LibreElec, I’ve got three boxes, and one of them is fine but the other two do it randomly.

Anything outside of watching PVR is fine but I’ve experienced it with both the TVH and MediaPortal plugin.

You can be watching TV and suddenly the image will get a red and green tint to it, if you change channel or skip back it will fix itself but usually it will come back again when it pleases.

It’s a little bit like the days of using the old fashioned 3d glasses that you used to put on to watch things in 3D, that’s the best way to explain it.

Any ideas? As I say, all other content is absolutely fine such as watching movies or TV shows.


You can choose “Disable deinterlacing” in Settings->System->CoreELEC and reboot, it solves an issue but deinterlacing will be disabled.
Also you can run command echo 1 > /sys/module/di/parameters/bypass_all before switching to that type of channels for temporary disable deinterlacing. echo 0 > /sys/module/di/parameters/bypass_all or reboot to return deinterlacing back

Have you tried swapping the good device’s boot media with the ‘faulty’ device’s media to see if the problem follows the media or if it is in the device itself?

Yes I tried that last night and the issue stays with the device itself.

I’ve turned deinterlacing off on both of them now and will monitor, so far they both appear to be working OK and to be honest the picture doesn’t look any worse or different to me so I don’t know if that’s a good thing or a bad thing lol.

What CPU’s are in the boxes you do and don’t have issues with just out of curiosity?

They are all S912 boxes with 2GB ram. Of the two that play up, one is a Plater M8S Pro the other is a H96 Pro Plus, not sure if they are just cheap clones as got them off Amazon. The one which works fine cost £27 off eBay and that’s an Ebox. The M8S and the Ebox one use the same DTB so I don’t think it’s relating to the DTB.

Had this for long with my Mecool m8s pro L
Did the deinterlacing thing from above and active cooling. Problem solved for me.

Yes both boxes now seem to be working perfectly, the picture looks just the same with interlacing disabled, should I expect a noticeable difference?

May be for sport channels
Also may be your tv makes some optimizations and you don’t see difference

We aren’t too big on sport so dont think it will be too much of an issue then :slight_smile: