Remote communication server failed to start? - Solved

After (manual) upgrade on my X92_S912 box to version .4 I get this message after every finished boot.
What does the message: “Remote communication server failed to start” refer to? What server?

Internet works, as everything else does; only have to use dirty regions line in advancedsettings.xml again to eliminate subtitle stutter…


Repeated the the procedure exactly the same way, but this time with .img.gz file instead with .tar.
Everything works fine and no more strange message.
Something wrong in that .tar file?

Could of done with an error log, please provide them when reporting issues as we don’t know what is going on otherwise.

Since it wasn’t a big deal, did not post any logs. I always try to resolve such things myself, before taking your time from more important work.
When I come acress a major obstacle, I’ll certainly attach all needed logs.

If there was something wrong with that .tar file, as you originally asked, that obviously would have been a ‘big deal’, which is what, most likely, prompted @anon88919003 to ask for logfiles. Perhaps the better approach would be to try and resolve it yourself before posting, and save everyone’s time? :+1:

I posted “Solved” before anybody else reported similar message, and the question about .tar file was meant to be hypothetical. Sorry if it didn’t sound that way.

Apologies, didn’t notice the change in the title.
For future reference, if you could include the fact that the thread can be closed in a post, that would be helpful :+1:

Found the cause for this message on my box with CE.8.90.4 with Kodi Alpha3

On my X92 box with clean install and only Rii mini i8+ wifi keyboard attached I get this message after every reboot if in Settings/Services/Remote control through applications on this machine is enabled. If I disable this setting the message does not appear any more after reboot/startup.

This message does not appear on CE.8.90.3 with Kodi Alpha2 no matter of the above setting.

Probably some change in Kodi from Alpha2 to Alpha3 is causing the message to appear…

As I posted in my thread I also see this message on first boot up but don’t require:

Settings/Services/Remote control through applications on this machine to be disabled.

The message doesn’t appear again once I reboot.
Going to test copying over the remote configuration files from this post to see if my issues with the Beelink remote are solved. I didn’t think this step was necessary.

EDIT: Copying the supplied remote files resolves the control problem.

Already fixed in the next version